nixp.ru v3.0

18 января 2017,
среда,
08:50:44 MSK

DevOps с компанией «Флант»
anonymous написал 28 марта 2005 года в 16:39 (351 просмотр) Ведет себя неопределенно; открыл 1814 темы в форуме, оставил 5575 комментариев на сайте.

Может дело и не в правах, но:

установил я себе Slackware10. Залогинился под рутом, все русифицировал и т.д.

Потом создал обычного юзера и занес его в группу users.

НО! у него, насколько я понял нехватает ниначе прав. За него неработает переключение раскладки клавиатуры, он неможет монтировать/размонтировать и т.д. Я незнаю где ему эти права назначить! Собственно переключение раскладки неработает даже и под рутом, хотя я правильно настроил xkb. Под рутом я могу переключать раскладку с помощью Kxkb (переключатель раскладок kde), а под юзером он незапускается. Пишет чтото типа: error loading language description.

Вот в конфиге xorg.conf:

Section «InputDevice»

Identifier «Keyboard1»

Driver «kbd»

Option «XkbModel» «pc105»

Option «XkbLayout» «us,ru(winkeys)»

Option «XkbOptions» «grp:ctrl_shift_toggle,grp_led:scroll»

EndSection

А раскладка без kxkb по ctrl+shift неменяется. Да мне хотьбы запустить этот kxkb под юзером.

iliya

Насчет монтирования:

fstab :

/dev/cdrom /mnt/cdrom auto noauto,users,ro 0 0

и пользователя включаешь в группу «cdrom».

Это если cdrom интересует, а если фатовские разделы, то смотри man mount.

Насчет иксов:

Очень странно что не работает, посмотри логи.

anonymous

Спасибо за users, забыл. Насчет лога: я в нем ничего непонимаю, единственное что привлекло внимание, это строчки:

(**) Option «CustomKeycodes» «off»

(**) Keyboard1: CustomKeycodes disabled

Что это за customkeykodes?

Весь лог положил сюда:

www.mgn.ru/~horrible/log.log

Может кто глянет и найдет проблему, ато мне приходится под рутом сидеть ((

iliya

Ну после просмотра ясно не стало, выложи ещё свой конфиг, ну и заодно

ls /var/log/packages/

anonymous

У меня такая же фигня в Слаке 10 с клавой. :(

anonymous

fon-alex, если решиш проблему, плиз скажи как на мыло или icq:221781279. Буду очень благодарен.

Genie

права на /tmp, /var/run, /var/lock какие?

на /dev/input/* ?

anonymous
Horrible[SUG]fon-alex, если решиш проблему, плиз скажи как на мыло или icq:221781279. Буду очень благодарен.

Всё оказалось просто и с точностью до наоборот чем в Сусе, вконтролцентре добавил рус.яз., выбрал свою клаву, внизу винкей и левее от него (сразу не заметил) включить латинскую раскладку, в следующей вкладке где группы присвоил на переключение групп альт+шифт и всё заработало, только индикатор раскладки в трее не показывает переключение. Вчера поставил Слаку 10.1 всё точь-в-точь, как и в 10 с раскладкой.

У меня глюк наблюдается, при выходе из Х-ов в консоли шрифт с высоту спичечного коробка, я даже не сразу сообразил что это шрифт. Приходится вслепую ребутиться, после ребута всё ок и локализация тож нормальная. Глюк замечен после установки Нвидиа дров, пробовал разные дрова, глюк присутствовал со всеми дровами, и в 10.0, и в 10.1 Слаках. Может, кто, чтонибудь посоветует?

metal

У меня в 10.1 схожая проблема (как мне кажется), при переключении в консоль исчезает русский, как я предполагаю шрифт сбрасывается на дефаутный, как это пофиксить пока не нашел. Наверное это подарки bash 3.0

anonymous

И что, ни кто из гуру не может подсказать в чём дело или где рыть? Какой то игнор полнейший, может уже ни кто Слакой не пользуется.

iliya

У меня была Слака 9.0 — нет проблем.

У меня была Слака 9.1 — нет проблем.

У меня была Слака 10 — нет проблем.

Сейчас Слака 10.1 — нет проблем.

Давай полный xorg.conf.

И за одно ls /var/adm/packages.

anonymous

Слишком длинные сообщения.

iliya
fon-alex
Слишком длинные сообщения.

Оправь мне на E-mail.

iliya [at] etprom.ru

anonymous

Я переустановил слаку и проблема исчезла!

iliya

А вот fon-alex так и не ответил.

Я ему решение послал, а он все молчит.

И что, ни кто из гуру не может подсказать в чём дело или где рыть? Какой то игнор полнейший, может уже ни кто Слакой не пользуется.

Ну так что решение помогло или как?

anonymous

Да ни фига я не получил, мой провайдер задолбал, опять с почтой что то. :(

anonymous

Илья мне сказал, что у тебя просто была закоментирована строчка с переключением раскладки. Посмотри в xorg.conf строчку типа

Option «XkbOptions» «grp:ctrl_shift_toggle,grp_led:scroll»

И убери перед ней символ #.

или пришли мне твой конфиг, я исправлю его и пришлю тебе.

anonymous
iliya
А вот fon-alex так и не ответил.

Я ему решение послал, а он все молчит.

Ну так что решение помогло или как?

Да с клавиатурой я справился, но всё равно спасибо за беспокойство. :)

Меня больше волновала вторая часть проблем описанных мной, а именно:

«У меня глюк наблюдается, при выходе из Х-ов в консоли шрифт с высоту спичечного коробка из разноцветных квадратиков, я даже не сразу сообразил что это шрифт. Приходится вслепую ребутиться, после ребута всё ок и локализация тож нормальная. Глюк замечен после установки Нвидиа дров, пробовал разные дрова, глюк присутствовал со всеми дровами, и в 10.0, и в 10.1 Слаках. Может, кто, чтонибудь посоветует?»

Вот это мне отравляет жизть. :((

iliya

Причем возникает он когда заходишь под рутом? Я не прав?

Если да то какой у тебя монитор, и чё запущенно?

anonymous

Монитор — iiyama MM9004UT A 19» (трубка), захожу и под юзером, и под рутом, в Х всё нормально, как тока выхожу из Х эта бадяга и проявляется, точно замечено после установки NVidia драйверов, причём перепробовал все версии. После перезагрузки системы шрифты нормальные в консоли.

iliya

Это я понял.

Такую бадягу наблюдал с радеоновскими дровами, поэтому и про монитор спросил.

Сам разобраться хочу, но та машина далеко, поэтому пиши мне на асю так будет проще.

Может разберемся.

anonymous

Надо бы завести себе аську, до сих пор не требовалась.

Genie

опции загрузки ядра какие?

проблемы сконсолью после установки драйверов nVidia возникают в большинстве случаев из-за того, что используется rivafb фреёмбуффер для консоли.

с vesa(-tng) таких проблем не встречется. ;)

anonymous

Опции загрузки ядра не трогал (слабоват ещё), всё по умолчанию. После установки драйвера прописал — nvidia в конфиге, если вернуть vesa, то консоль нормально отображает шрифты, но тогда в Х-ах полный бардак (разрешение экрана на 1280х1024 не правильно отображает).

Genie

а зря, что и не смотрел даже.

может ты всёже, поглядишь и напишешь их тут?

кстати, тут встаёт вопрос: а что у тебя загрузчиком стоит?

lilo (/etc/lilo.conf), grub (/boot/grub/grub.conf) или что-то третье?

anonymous

Загрузчик — Lilo, опции посматрю, где только? Сейчас в винде нахожусь, т.к. выход в инет через прокси, в Слаке ещё не настроил (не знаю как), в Сусе запускал в vine GateKeeper, а здесь нет vine, устоновить не смог, кароче — полный, этот — новичёк :)

Genie
Прислано: сегодня в 10:34:18

Загрузчик — Lilo, опции посматрю, где только?

хммм. написал же даже в скобочках.. ;)

lilo (/etc/lilo.conf)

а чтобы из винды глядеть — для TotalCommander есть плагин такой

кстати, насколько я помню, есть и для виндов драйвер ext2fs — поищи на sf.net

anonymous

ext2fs — эта фиговина у меня стоит, но она видет только ext2fs

anonymous
Genie
а зря, что и не смотрел даже.

может ты всёже, поглядишь и напишешь их тут?

кстати, тут встаёт вопрос: а что у тебя загрузчиком стоит?

lilo (/etc/lilo.conf), grub (/boot/grub/grub.conf) или что-то третье?

# LILO configuration file

# generated by 'liloconfig'

#

# Start LILO global section

append=«hdc=ide-scsi»

boot = /dev/hda

message = /boot/boot_message.txt

prompt

timeout = 20

# Override dangerous defaults that rewrite the partition table:

change-rules

reset

# VESA framebuffer console @ 1024×768x256

vga = 773

# Normal VGA console

# vga = normal

# VESA framebuffer console @ 1024×768x64k

# vga=791

# VESA framebuffer console @ 1024×768x32k

# vga=790

# VESA framebuffer console @ 1024×768x256

# vga=773

# VESA framebuffer console @ 800×600x64k

# vga=788

# VESA framebuffer console @ 800×600x32k

# vga=787

# VESA framebuffer console @ 800×600x256

# vga=771

# VESA framebuffer console @ 640×480x64k

# vga=785

# VESA framebuffer console @ 640×480x32k

# vga=784

# VESA framebuffer console @ 640×480x256

# vga=769

# End LILO global section

# Windows bootable partition config begins

other = /dev/hda1

label = Windows

table = /dev/hda

# Windows bootable partition config ends

# Linux bootable partition config begins

image = /boot/vmlinuz

root = /dev/hdb2

label = Linux

read-only

# Linux bootable partition config ends

anonymous

Ну и до кучи, вот здесь прописал «nvidia»:

Section «Device»

Identifier «NV AGP»

VendorName «nvidia»

Driver «nvidia»

#VideoRam 4096

# Insert Clocks lines here if appropriate

EndSection

# ********************************************************************

# Screen sections

# ********************************************************************

# Any number of screen sections may be present. Each describes

# the configuration of a single screen. A single specific screen section

# may be specified from the X server command line with the «-screen»

# option.

Section «Screen»

Identifier «Screen 1»

Device «NV AGP»

Monitor «My Monitor»

anonymous

Изменил вот эту часть

reset

# VESA framebuffer console @ 1024×768x256

vga = 773

# Normal VGA console

на

reset

# VESA framebuffer console @ 1024×768x256

vga = 775

# Normal VGA console

Не знаю почему не изменилось разрешение, но вибирал 1280х1024.

Теперь при выходе из Х шрифты нормальные, но, блин, ошибок выдаёт после этого тьму, на два экрана.

fly4life
fon-alex
Не знаю почему не изменилось разрешение, но вибирал 1280х1024.

Потому что это два режима с одинаковым разрешение экрана, но с разной битностью цвета (793 — это для 32k, 795 — это для 16M)

fon-alex
Теперь при выходе из Х шрифты нормальные, но, блин, ошибок выдаёт после этого тьму, на два экрана.

Чего за ошибки-то?

anonymous

Да вроде связано с шрифтами, я от бешенства стал их добавлять во все папки, потом удалил из некоторых, в контрол центре всё это делал, а впапке TTF не стал их удалять , хрен их знает какие там были, а какие я добавил, короче бардак конкретный, мне легче Слаку переустановить наверное, чем поправить.

А на счёт битности, выбирал ту же только с др. разрешением экрана.

Может есть способ шрифты вернуть каторые были изначально поставлены?

Master
fon-alex
Может есть способ шрифты вернуть каторые были изначально поставлены?

Изначально — это из дистрибутива?

Грохни /usr/X11R6/lib/X11/fonts

и поставь пакеты x11-fonts-* которые ты ставил из ветки Х

Horrible

Недавно у меня повторилась проблема с переключением раскладки. Проблема решилась сама собой, когда я уже был готов биться головой об стенку. Все оказалось из-за того, что на разделе /var кончилось место!

Спасибо большое iliya, за то, что помог решить эту проблему!

a110c
fon-alex
У меня глюк наблюдается, при выходе из Х-ов в консоли шрифт с высоту спичечного коробка, я даже не сразу сообразил что это шрифт. Приходится вслепую ребутиться, после ребута всё ок и

Не надо ребутиться. Сделай выполняемый скриптик вроде такого:

#!/bin/sh

setfont koi8r-8×14

setfont koi8r.8×8

clear

Запускай после возвращения в консоль. Имя присвой такое, чтобы «вслепую» легко было набрать ~/твой_скрипт.

А лучше — запускай иксы из режима 80×25, в него возвращаться будешь нормально. И выруби фреймбуфер, он замедляет работу иксов. Уж выбери, что тебе нужнее: иксы с акселератором или быстрая цветная консоль с красиывми фонтами.

И пиши вопросы покороче, а то роман какой-то получается с сотней разных не связанных друг с другом проблем.

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.