nixp.ru v3.0

23 мая 2017,
вторник,
00:31:41 MSK

DevOps с компанией «Флант»
spacer написал 8 мая 2005 года в 16:27 (496 просмотров) Ведет себя как мужчина; открыл 11 тем в форуме, оставил 36 комментариев на сайте.

Вообщем сабж слегка достал :-))

8.0 с темиже на стройками работал

а это ни вкакую

SuSE Meta pppd (smpppd-ifcfg), Version 1.58 on linux.

Status is: disconnected

trying to connect to smpppd

connect to smpppd

Status is: disconnected

Status is: connecting

pppd[0]: Plugin passwordfd.so loaded.

pppd[0]: --> WvDial: Internet dialer version 1.54.0

pppd[0]: --> Initializing modem.

pppd[0]: --> Sending: ATZ

pppd[0]: ATZ

pppd[0]: OK

pppd[0]: --> Sending: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

pppd[0]: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

pppd[0]: OK

pppd[0]: --> Sending: ATM1

pppd[0]: ATM1

pppd[0]: OK

pppd[0]: --> Modem initialized.

pppd[0]: --> Sending: ATDP518304

pppd[0]: --> Waiting for carrier.

pppd[0]: ATDP518304

pppd[0]: CONNECT 57600/V32b 14400/V42b

pppd[0]: --> Carrier detected. Chatmode finished.

pppd[0]: Serial connection established.

pppd[0]: Renamed interface ppp0 to modem0

pppd[0]: Using interface modem0

Status is: connecting

pppd[0]: Connect: modem0 <--> /dev/ttyS1

pppd[0]: Hangup (SIGHUP)

pppd[0]: Modem hangup

pppd[0]: Connection terminated.

Status is: disconnected

pppd[0] died: A modem hung up the phone (exit code 16)

Шо ему не так непойму.

Може кто чего подскажет

Genie

есть подозрение на то, что добавление в конфиг pppd опции «deflate 0» может помочь.

так же и «novj*» — их тоже можно попробовать.

spacer

Пните не разумнного хде это делать

Genie

в районе /etc/ppp/options

spacer

deflate 0 помогло. Но с другим провайдером.

А надо то со своей рабочей машиной конектится.

получается что на той стороне что то не так.

Офтопик конектится minicom тоже

А тут pppd вывалится с 16 кодом.

Где че подправить, что пасматреть?

Рута на FreeBSD есть.

Заранее спасибо за любые советы.

Лог соединения остался прежним, как в первой мессаге.

Sasha2

Наверное модем US Robotics V.Everything.

По второй строке инициализации мне кажется, что это именно так.

Так вот. У меня в SuSe 9.3 тоже после инсталляции такая же строка была сгенерирована.

Убери первую ATZ (она вообще не нужна).

Вместо нее укажи такую строку AT&F1&D2V1Q0E0S0.

Если хочешь оставь ATZ.

Но тогда эту строку поставь второй.

Good luck

spacer

Да нет модем у меня ZyXEL U-1496U

Genie

добавь в опции «debug kdebug 15» и попробуй соединиться.

после этого смотри, что у тебя в логе появилось.