nixp.ru v3.0

29 мая 2017,
понедельник,
09:00:03 MSK

DevOps с компанией «Флант»
kant76 написал 27 сентября 2005 года в 15:26 (430 просмотров) Ведет себя неопределенно; открыл 1 тему в форуме, оставил 1 комментарий на сайте.

Пытаюсь поставить Apache+php .

Апач ставил так:

#./configure --enable-module=so

PHP так:

#./configure --with-apxs=/usr/local/apache/bin/apaxs --with-interbase --with-gd enable-ftp

Вроде все сделал правильно — все встало. Сам по себе Apache работает. Но если в /usr/local/apache/conf/httpd.conf прописать LoadModule php4_module libexec/libphp4.so (apache сам ето прописывает при установке с модулем php) то при попытке запустить апач — выдается ошибка:

Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:

Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: cannot restore segment prot after reloc: Permission denied

./apachectl start: httpd could not be started

в чем тут грабли?

propeller

А ты проверял, там файл-то есть по пути /usr/local/apache/libphp4.so?

как мне кажется, по умолчанию этот модуль пхп ставится в /usr/local/apache/modules.

Да и php у тебя 4, или 5?

kant76

пхп у меня четветрый и пути верные… А решение в следующем (один грамотный товарищь вчера подсказал на форуме PHPClub.ru) Вся эта проблема связана с SELinux. Пришлось ее отключить и все заработало… Как их подружить пока не знаю