nixp.ru v3.0

17 октября 2017,
вторник,
01:20:30 MSK

DevOps с компанией «Флант»
NixoiD написал 2 ноября 2004 года в 02:02 (363 просмотра) Ведет себя неопределенно; открыл 1 тему в форуме.

Привет!

Ставлю Gentoo 2004.2 Linux Center Editionи по ходу установки возникло много вопросов. Большинство из них удалось порешать, на форуме Gentoo.ru, а все что не удалось пишу сюда.

Ставил со stage1, ядро скачал и поставил оригинальное 2.6.9

PPP:

2.4.1 ставиться не захотел(ошибка при сборке), так что поставил 2.4.2(из ебилда)

Подключается всё нормально и скриптом и wvdial’oм. Собственно скрипт и опции ppp взял из слаки — там(здесь ;)) у меня всё работает. А проблема собственно в том, что не под рутом не лукапятся ip-адреса хостов. Т.е. Если я воожу ping ya.ru — unknown host, а если ip — всё ок.

Я dnsdomainname криво как-то указал при установке, так что на welcome-скрине пишется что-то вроде unknown_domainname — может это изза этого?

Так, дальше nvidia-kernel

# emerge nvidia-kernel

# emerge nvidia-glx

всё ок. Дописалось в /etc/modules.d, modules-update, вобщем всё как надо, но

bash-2.05b# modprobe nvidia

FATAL: Error inserting nvidia (/lib/modules/2.6.9/video/nvidia.ko): Invalid module format

И ещё трабла с ядром: не получается нормально настроить фреймбуфер(или через что оно там это делает) чтобы в консоли нормальное разрешение было.

При конфигурации ядра включил там все галочки на эту тему(какие точно уже не помню, но 2 раза пересобирал — не помогло). В lilo.conf vga=788(пробовал и другие — результат один).

В самом начале загрузки(когда обычно переключается видеорежим) вместо нормального переключения экран мелькает как если бы процес шел нормально, но потом сразу же обратно в 640×480. Никаких надписей во время мелькания не видно. Видяха — Riva tnt2 m64. Вот что в dmesg на эту тему:

rivafb: nVidia device/chipset 10DE002D

rivafb: RIVA MTRR set to ON

rivafb: PCI nVidia NV4 framebuffer ver 0.9.5b (nVidiaRIVA-VTNT2, 32MB @ 0xE4000000)

vesafb: abort, cannot reserve video memory at 0xe4000000

vesafb: framebuffer at 0xe4000000, mapped to 0xd3809000, size 1875k

vesafb: mode is 800×600x16, linelength=1600, pages=3

vesafb: protected mode interface info at c000:04e0

vesafb: scrolling: redraw

vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0

fb1: VESA VGA frame buffer device

А ещё есть такой модуль hsfserial(6 версия)… ;) Это выньмодем. Он коммерческий. Процесс поиска и установки крэка под линукс(!) более подробно я описал здесь:

http://www.linuxshop.ru/forum/viewtopic.php?p=95854#95854

С ним вот такая трабла: устанавливаю по инструкции

make install

hsfconfig

работает вроде как всё, но когда я отключаюсь от инета и потом заново подключаюсь или перезагружаюсь что-то с ним происходит. Он или выключается или просто не загружается соответственно. И pppd или wvdial при попытке инициализировать модем вешают систему(kernel panic) или настолько затормаживают что спасает только reset. В /etc/init.d/hsf вроде бы всё правильно. В мандраке 10.1 community работал нормально, так что теоретически его настроить можно. Ах да, =) спасает переустановка модуля. Причем не просто hsfconfig, а с make install, который впринципе ничего нового не делает. И так каждый раз. Пока он не установлен/включен /etc/ttySHSF0 не существует, но это вроде логично. Ядро я изза этого и обновил до 2.6.9 — думал может оно(2.6.7-r13) кривое. Зря надеялся. ;)

Шрифты

Поставил ХFree 4.3(тот, что на дисках был), поставил шрифты в /usr/кудато_там/fonts/cyrillic,TTF и.т.д. всё как в слаке, mkfontdir,scale и.т.д. и.т.п.

Не работают только в gtk2(в первой нормально).

Мелочь вроде бы, но сделать тоже надо. :)

Ну и напоследок самое самое:

кому нибудь удавалось в fluxbox-0.9.10 нормальную поддержку русских шрифтов прикрутить? Если да то как.

В <0.9.10 у меня тоже всё работает. ;)

Спасибо всем кто дочитал до конца, надеюсь поможете. :)

Longobard

флюкс 0.9.10 — коряффка.

Откатись на 0.9.9

metal
FATAL: Error inserting nvidia (/lib/modules/2.6.9/video/nvidia.ko): Invalid module format


.

Ищи в форуме проблема драйверов nvidia и 2.6.9 обсуждалась