nixp.ru v3.0

25 мая 2017,
четверг,
00:27:59 MSK

DevOps с компанией «Флант»
Аватар пользователя splinter
splinter написал 5 июня 2006 года в 10:41 (341 просмотр) Ведет себя как четкий пацан; открыл 134 темы в форуме, оставил 1458 комментариев на сайте.

Вот не въеду, откуда взялись 3 ветки ядра 2.2.х.х 2.4.х.х 2.6.х.х, раньше думал что 2.6 самое новейшее, недавно взял диск с журнала хакер там были новые ядра ко всем трем веткам! я думал 2.2 давно ушло в историю!, вабще какой смысл в делении ядер ? чем они отличаются? на какое ядро действительно стоит обратить внимание. И еще недавно была новость о уязвимости критической XORG, вы не в курсе уязвимость уже исправленна?

fly4life
splinter
Вот не въеду, откуда взялись 3 ветки ядра 2.2.х.х 2.4.х.х 2.6.х.х, раньше думал что 2.6 самое новейшее, недавно взял диск с журнала хакер там были новые ядра ко всем трем веткам! я думал 2.2 давно ушло в историю!, вабще какой смысл в делении ядер ? чем они отличаются? на какое ядро действительно стоит обратить внимание.

Ядра никто не делит. Просто с выходом новой ветки, некоторое время поддерживается ядро из старой.

2.2.х, да, уже давно ушло в историю (вон, посмотри на kernel.org, когда оно последний раз обновлялось). Сейчас обновляются только ветки 2.4.х и 2.6.х. Причём, в 2.4.х фиксятся, в основном, только баги, а разработка новых фич ведётся в 2.6.х (т.е. и на 2.4 потихоньку начинают забивать).

splinter
И еще недавно была новость о уязвимости критической XORG, вы не в курсе уязвимость уже исправленна?

Это каким-то образом относится к вопросу «Ядра»?

P.S. Поправочка, в версиях 2.2 и 2.4 всего по три цифры ;)

splinter

спасибо, ситуация потихоньку начинает прояснятся, так все таки если у меня стоит ALTLinux2.4 с ядром 2.4.29 то мне лучеше перейти на 2.6.15? кстати я слышал что разработчики альта не советуют этого делать так как не дают гарантии что все будет хорошо работать.

Dr. Evil

меня очень удивляют дистрибутивы, которые по дефолту включают 2.4.*, а 2.6 только как опция

2.4.* уже так не развивается, как хотелось бы. в 2.6.* постоянно добовляют новые фичи, драйверы устройств, чтобы тебе и мне было удобно работать, например, с мультимедия устройставми. зачем использовать то, что кто-то не понятно почему называет более стейбл? если все мировые лидеры в производстве Linux-дистрибутивов включают только 2.6.*, то надо задуматься…

мы тут с fly4life столкнулись с таким чудом программерской мысли и ужаснулись. высказался я бы тут, но боюсь, что война начнется

fly4life
splinter
спасибо, ситуация потихоньку начинает прояснятся, так все таки если у меня стоит ALTLinux2.4 с ядром 2.4.29 то мне лучеше перейти на 2.6.15? кстати я слышал что разработчики альта не советуют этого делать так как не дают гарантии что все будет хорошо работать.

Ну да, помню, как intelligent <font size=«-2»>(хоть и нечастый, но всё же посетитель данного форума)</font> имеено в AltMaster 2.4 пытался перейти с установленного по умолчанию ядра 2.4 на 2.6. Наблюдать было весело ;). Через некоторое время незавидного секса он даже дистрибутив сменил ;). Правда, не исключаю, что на предмет перехода в Альте с 2.4 на 2.6 есть какая-нибудь инструкция, описывающая последовательность нетривиальных приседаний — мы её искать не стали… Можешь поискать сам, вдруг не так страшен чёрт, как его малюют.

А вообще, если всё работает, нового железа добавлять не предвидится, то смысла переходить на 2.6 пока нет.

splinter

думаю они считают эту ветку более стабильной. ИМХО

fly4life
Dr. Evil
меня очень удивляют дистрибутивы, которые по дефолту включают 2.4.*, а 2.6 только как опция

2.4.* уже так не развивается, как хотелось бы. в 2.6.* постоянно добовляют новые фичи, драйверы устройств, чтобы тебе и мне было удобно работать, например, с мультимедия устройставми. зачем использовать то, что кто-то не понятно почему называет более стейбл? если все мировые лидеры в производстве Linux-дистрибутивов включают только 2.6.*, то надо задуматься…

Насколько я понимаю, сам AltLinux 2.4 вышел, когда ядро 2.4 было стабильным, а 2.6 всё ещё сыроватым. Вот и предлагали по умолчанию то, что понадёжнее.

splinter
А вообще, если всё работает, нового железа добавлять не предвидится, то смысла переходить на 2.6 пока нет

оно то вроде бы и так, я вообще то поставил себе уже асп10, но линукс у меня стоит для эксперементов, я его можно сказать пытаюсь понять и осмыслить, поэтому хочу попробовать поставить и 2.2 :)

fly4life
splinter
оно то вроде бы и так, я вообще то поставил себе уже асп10, но линукс у меня стоит для эксперементов, я его можно сказать пытаюсь понять и осмыслить, поэтому хочу попробовать поставить и 2.2 :)

Пытаешься «осмыслить линукс» через установку старья? Странное занятие…

splinter

а почему бы нет? в конце концов по старью литературы больше, к тому же дома у меня два компа один старенький для опытов другой не такой старенький но тоже для опытов :)) я на старый поставил slackware 9.1 все мне говорили это сложный линукс не для начинающих, а он встал заработал на ура, я в нем даже ядро с 2.2 на 2.6 поставил :))) счастья было не передать словами :) а ты говоришь старье!

fly4life
splinter
а почему бы нет? в конце концов по старью литературы больше,

Документацию надо искать не по количеству, а по актуальности.

splinter
к тому же дома у меня два компа один старенький для опытов другой не такой старенький но тоже для опытов :)) я на старый поставил slackware 9.1 все мне говорили это сложный линукс не для начинающих, а он встал заработал на ура, я в нем даже ядро с 2.2 на 2.6 поставил :))) счастья было не передать словами :) а ты говоришь старье!

Просто лично мне не ясен смысл в установке дааавно устаревшего и неразвивающегося 2.2.х (тем более, что ты сразу же установил 2.6). Что ты хочешь «понять и осмыслить» таким образом?

P.S. В «коробке» Slackware 9.1 разве ядро 2.2?

splinter

тебе все вопросы выложить? боюсь статья получится :) я не из коробки его взял а добросовестно спер с локального фтп. А понять я хочу почему такое изобилие одной операционки, как вообще работает система Линукс и почему на одни и те же дистрибутивы так по разному устанавливается сырье, а еще как настроить vpn-клиента, почему постоянно от меня требуются какие то библиотеки, что такое зависимости, почему программировать на каликсе удел неудачников и многое многое другое!!!!

Дмитрий Шурупов

Установка ядра 2.2 эти вопросы не решит. А если и каким-нибудь чудным образом решит, то не лучше, чем 2.4 и/или 2.6.

splinter

эх Дмитрий, если бы Линукс был таким же как твой аватар. :)

Dr. Evil

то, чем ты занимаешься, называется регресс…

что в сегодняшней реальности, честно говоря, довольно-таки странно. убеждать тебя использовать тот или иной дистрибутив никто, надеюсь, не будет — это дело каждого в отдельности. но то, что на разработку нового программного обеспечения тратятся огромные средства/время/… — не отнять. если тебе нравится танцевать с бубнами, то ты можешь поставить хоть, например, RH 7.2 на компьютер с SATA дисками и радоваться. только не понятно зачем…

splinter
можешь поставить хоть, например, RH 7.2 на компьютер с SATA дисками и радоваться. только не понятно зачем…


ты будешь смеятся пытался ставить RedHat 6.1 притом на машину с RAID-контроллером :)

fly4life
splinter
ты будешь смеятся пытался ставить RedHat 6.1 притом на машину с RAID-контроллером :)

Ну и какой полезный для себя опыт ты из этого вынес? ;)

splinter

Это бесполезно, хотя и дрова линуксоидные на raid — контроллер были, когда нить извращусь и поставлю :) И вообще вопрос был о ядрах. Я вот не пойму что ядра 2.2 и 2.4 хуже и нестабильнее чем 2.6? Почему их забросили (2.2)? или они изначально были неправильно сделанны что не имеет смысла их дальше развивать?

Genie

rtfs ядра 2.2

может быть ответ найдёшь, если обладаешь достаточной квалификацией.

fly4life
splinter
Это бесполезно, хотя и дрова линуксоидные на raid — контроллер были, когда нить извращусь и поставлю :) И вообще вопрос был о ядрах. Я вот не пойму что ядра 2.2 и 2.4 хуже и нестабильнее чем 2.6? Почему их забросили (2.2)? или они изначально были неправильно сделанны что не имеет смысла их дальше развивать?

Гм. Да, порой попадаются вопросы, ставящие в тупик. Как этот твой.

Мне, вот, интересно, а ты не задумывался над тем, что версия 2.6 — это эволюционное развитие версии 2.4, которое, в свою очередь, является развитием 2.2? =/ А тот факт, что с выпуском, например, новой версии какого-то линуксового дистрибутива со временем забивают на его предыдущие, тебя тоже клинит?

splinter

задумывался только это как то все равно не правильно. Что бы создавать новую ветку надо в корне менять старую, а когда я вижу одновременный релиз 2.6.15 и 2.4.32 да еще и 2.2.22 (точно не помню) я начинаю охренневать с такой анархии и непоследовательности, мне нужно самое лучшее и стабильное ядро, я вижу параллельное развитие всех трех, что это за змей горыныч такой??? и вообще не заметил я разницы никакой между 2.4 и 2.6 !!! если это устарелло зачем его продолжать выпускать патчи?? есть ведь хорошая поговорка … как мертвому припадки.

fly4life
splinter
задумывался только это как то все равно не правильно. Что бы создавать новую ветку надо в корне менять старую, а когда я вижу одновременный релиз 2.6.15 и 2.4.32 да еще и 2.2.22 (точно не помню) я начинаю охренневать с такой анархии и непоследовательности, мне нужно самое лучшее и стабильное ядро, я вижу параллельное развитие всех трех, что это за змей горыныч такой??? и вообще не заметил я разницы никакой между 2.4 и 2.6 !!!

Если не замечаешь ты — это ещё не значит, что её нет вовсе ;).

splinter
если это устарелло зачем его продолжать выпускать патчи?? есть ведь хорошая поговорка … как мертвому припадки.

В 2.6, по сравнению с 2.4, очень много чего добавили/исправили/поломали/переделали, поэтому безболезненный переход с 2.4 на 2.6 не всегда возможен (либо просто не стоит усилий, если 2.4 полностью устраивает). Соответственно, и приходится латать кое-какие дыры в 2.4, т.к. оно ещё много где используется.  Отсюда и новые версии в старой ветке.

P.S. 2.2, кстати, уже дааавно не обновляется.

splinter

то есть по твоим словам на мигрировать на ветку 2.6 ?

fly4life
splinter
то есть по твоим словам на мигрировать на ветку 2.6 ?

Не понял вопроса.

splinter

ну вот купил я как то на nixp.ru ALTLinux2.4, у него ядро 2.4.29 Альт мне очень понравился, а теперь ты говоришь что ядро 2.4 это уже почти прошлое, а разработчики альта говорят не рекомендуем ставить ядро 2.6 а то мы не отвечаем за последствия, что делать менять дистрибутив или жить со старым ядром?

fly4life
splinter
ну вот купил я как то на nixp.ru ALTLinux2.4, у него ядро 2.4.29 Альт мне очень понравился, а теперь ты говоришь что ядро 2.4 это уже почти прошлое, а разработчики альта говорят не рекомендуем ставить ядро 2.6 а то мы не отвечаем за последствия, что делать менять дистрибутив или жить со старым ядром?

Если тебя по каким-то причинам не устраивает дистрибутив, то его однозначно надо менять. Кстати, твой Alt Master 2.4 <font size=«-2»>(такой да?)</font> уже староват (кажись, у альтовцев там что-то с версией 3.0 уже вышло).

splinter

Складывается впечатление что они выпускают новые дистрибудивы со скоростью выхода патчей :) я ж так денег не напасусь. В этом отношении в BSD как то все более ровно и ясно.

fly4life
splinter
Складывается впечатление что они выпускают новые дистрибудивы со скоростью выхода патчей :) я ж так денег не напасусь. В этом отношении в BSD как то все более ровно и ясно.

Кто «они»? Альтовцы?! Да не, уж в сравнении с их продуктами — это, скорее, версии BSD выходят «со скоростью выхода патчей» ;)

splinter

Значит получается что наиболее устойчивое пропатченное ядро на сегодняшний момент 2.2.22 и если я задумал поднять htpd или еще что нить такое то лучше использовать его?

fly4life
splinter
Значит получается что наиболее устойчивое пропатченное ядро на сегодняшний момент 2.2.22 и если я задумал поднять htpd или еще что нить такое то лучше использовать его?

Что-то я не уследил за полётом твоей мысли, приведшему к такому.. ммм.. сногсшибательному выводу.

Нет, «на сегодняшний момент» ядро 2.2.22  - это наиболее устаревшее и, как раз, лет сто уже непатченное ядро. Для использования где-либо оно непригодно вообще.

splinter

:) эта же участь ждет и ядро 2.4? а как скоро это может произойти. извините уж за совсем детские вопросы. :(

fly4life
splinter
:) эта же участь ждет и ядро 2.4? а как скоро это может произойти. извините уж за совсем детские вопросы. :(

Уверен, что и 2.6 тоже ;). Насчёт сроков жизни версий ядра — к экстрасенсам, наверное.

REDkiy

У меня есть в хозяйстве машинка на Celeron 375, на матери от Realtek с VIA’вскими чипами.Видяха так и непонял какая,да и не разбирался.

Ставил на неё Debian GNU/Linux «Sarge».

По умолчанию там предлагается ядро версии 2.4,но при загрузке инсталлера можно выбрать и версию 2.6.

При загрузке программы установки на ядре 2.4, выскочила ошибка:

Не найден жесткий диск!

Я загрузился на ядре 2.6 и установка прошла гладко.

Ядро версии 2.2 я не пробовал.

И небуду.

Понять любую операционную систему можно только пожив в ней,решая реальные повседневные проблемы.

А перепробовав множество старых и устаревших версий ядра можно понять только то,что эти версии стары и устаревшие.

8-)

metal

Ну это частный случай. 2.4 не на столько старое чтобы не могло подхватить железо времени celeron-375. Хотя конечно старые ядра не поддерживают свежее железо, но вот бывает и наоборот новые ядра не поддерживают старое железо:( Фиксы для старых ядер выпускаются именно для этого. Если у тебя есть какое-то железо, софт, которое уже работает и нет возможности(желания) обновлять, можешь использовать старые ядра. Так alt linux 2.4 использует ядров ветки 2.4 в силу своего возраста.

splinter

раздобыл сегодня Slackware 10.2 дык ядро там тоже ветки 2.4.31, разработчики дистрибутивов как то панически боятся боятся 2.6.х :)

Dr. Evil

не боятся, а, видимо, предпочитают. или же считают, что 2.6.* еще не столь стабильна. ты, если хочешь, можешь перевести эту версию Слаки и на 2.6.*. Все, что для этого нужно, есть.

splinter

все что мне нужно это настроить vpn :( а там пусть хоть ядро 1.0 будет :)) шутка конечно.

Dr. Evil

настройка vpn никак не связана с вопросом о ядрах..

Genie
настройка vpn никак не связана с вопросом о ядрах..

ну не скажи. mppe унутре только в новых ядрах. в старых — надо патчить.

с mppc надо прикладывать отдельно во всех случаях.

почему про это? ну так во многих местах счас mppe/mppc для vpn используют. для win* совместимости…

Dr. Evil

так и знал, что кто-нибудь да прицепится… даже не сомневался, что это будет Genie.

начало темы было просто совсем не связано имменно с настройкой vpn. если автор таким образом хотел для себя определить ветку ядра, которая поможет ему настроить vpn, то это как-то странно.

fly4life
Genie
ну не скажи. mppe унутре только в новых ядрах. в старых — надо патчить.

с mppc надо прикладывать отдельно во всех случаях.

С версии 2.6.15 в ядре уже есть и mppc.

splinter

а в ветке 2.4??? вот поставлю сегодня слаку 2.4.31 пропатчу до 2.4.32 и окажется что mppe поддержки там нет? вы меня расстроили :(

splinter
так и знал, что кто-нибудь да прицепится… даже не сомневался, что это будет Genie


- истинна рождается в споре. :)

Genie
С версии 2.6.15 в ядре уже есть и mppc.

ась? :) где?

$ locate mppe
/lib/modules/2.6.16.18-smp.k7.badram/kernel/drivers/net/ppp_mppe.ko
/usr/src/kernel-headers-2.6.16.18-smp.k7.badram/include/config/ppp/mppe
/usr/src/kernel-headers-2.6.16.18-smp.k7.badram/include/config/ppp/mppe/module.h
/usr/src/kernel-source-2.6.16.18-smp.k7.badram/drivers/net/ppp_mppe.c
/usr/src/kernel-source-2.6.16.18-smp.k7.badram/drivers/net/ppp_mppe.h
$ locate mppc
$

:D

конфиг — могу дать. скажешь, что я не включил?

а в ветке 2.4??? вот поставлю сегодня слаку 2.4.31 пропатчу до 2.4.32 и окажется что mppe поддержки там нет? вы меня расстроили :(

скорее всего — не будет. ибо для этого надо отдельно накладывать патч.

splinter

НИчего не пойму WinXP занимает местка на одном диске, дистрибутивы Linux свыше 2 дисков (это минимум видел 13сд)и что бы его довести до ума надо еще столько же найти в инете, как это по вашему называется?

splinter

гы прикольная у вас тут классификация, после сотого сообщения я наконец то стал юниксоидом :)) ржунимагуподстоломикатаюсьпополу :)))

Genie
НИчего не пойму WinXP занимает местка на одном диске

а что там есть необходимого для работы. ну, поставил ты голую винду. что дальше? ещё диск — офис. ещё диск — фотошоп. и ещё диск-другой-третий драйверов, дополнительных программ,…

которые тебе ещё покупать надо. и, по хорошему, не за 80-100р/диск. а с лицензией на использование.

дистрибутивы Linux свыше 2 дисков (это минимум видел 13сд)и что бы его довести до ума надо еще столько же найти в инете

качаются только обновления. а их — за полгода всего-то около 300Мб.

как это по вашему называется?

open-source. :D

гы прикольная у вас тут классификация

ну хоть какая-то, да есть. времени нет переделать всё тут нафик… и это — в том числе.

но это уже глубокий оффтопик. посему — вспомни про название темы и думай в этом направлении. ;)

fly4life
Genie
ась? :) где?

$ locate mppe
/lib/modules/2.6.16.18-smp.k7.badram/kernel/drivers/net/ppp_mppe.ko
/usr/src/kernel-headers-2.6.16.18-smp.k7.badram/include/config/ppp/mppe
/usr/src/kernel-headers-2.6.16.18-smp.k7.badram/include/config/ppp/mppe/module.h
/usr/src/kernel-source-2.6.16.18-smp.k7.badram/drivers/net/ppp_mppe.c
/usr/src/kernel-source-2.6.16.18-smp.k7.badram/drivers/net/ppp_mppe.h
$ locate mppc
$

:D

конфиг — могу дать. скажешь, что я не включил?

Пардон, модуль есть только для mppe. Однако отдельно патч для mppc наложить не получится, т.к. существующий включает поддержку и mppe, и mppc, и, как выяснилось из гугла, с ядрами, в которые mppe уже включено (>= 2.6.15), он несовместим. Т.е. получается, что либо компрессия уже в модуле mppe, либо счастливые обладатели свежих линуксовых ядер остались и вовсе без mppc. Ех, нету сейчас под рукой 2.6.15, чтобы посмотреть…

Genie

ну, mppe точно работает, поскольку это я экспериментально дома, при настройке pptp выяснил.

есть ли там компрессия — которая mppc — смотреть не подумал.. :)

так что — до вечера я, пожалуй, по этому поводу ничего не скажу…

splinter

ну и сколько тебе вечеров надо что бы это выяснить?

Genie

вяснить — вечер.

собраться-таки выяснить — хз сколько.

Genie
а что там есть необходимого для работы. ну, поставил ты голую винду. что дальше? ещё диск — офис. ещё диск — фотошоп. и ещё диск-другой-третий драйверов, дополнительных программ,…

которые тебе ещё покупать надо. и, по хорошему, не за 80-100р/диск. а с лицензией на использование.

Подтверждаю: если разуть глаза и посмотреть, чем занят диск с хп, то хочется заплакать… Если посмотреть, сколько софта идёт на компакт-диске ТОГО ЖЕ ОБЪЁМА с УБунту, то хочется ущипнуть себя и проверить, не сон ли это… И это бесплатно, и легально…

В тему: отцы, проходила информация, что новые 2.6.17 быстрее предыдущих ядер. Вопрос: 1) так ли это и 2) насколько.

fly4life
virens
В тему: отцы, проходила информация, что новые 2.6.17 быстрее предыдущих ядер. Вопрос: 1) так ли это и 2) насколько.

А взять, проверить и рассказать отцам, на самом ли деле это так? ;)

Да, быстрее в чём оно должно быть-то?

8084

Про mppc , ищите сначала патч, выдерающий из >=2.6.15 mppe ;)

Или вот

http://dimez.findall.ru/docs/mppe_mppc/