nixp.ru v3.0

28 мая 2017,
воскресенье,
23:24:07 MSK

DevOps с компанией «Флант»
Longobard написал 6 марта 2004 года в 21:00 (389 просмотров) Ведет себя как мужчина; открыл 291 тему в форуме, оставил 2499 комментариев на сайте.

Такая вот возникла трабла:

checking for GLIB — version >= 2.0.6…

* 'pkg-config --modversion glib-2.0\′ returned 2.3.2, but GLIB (2.0.6)

* was found! If pkg-config was correct, then it is best

* to remove the old version of GLib. You may also be able to fix the error

* by modifying your LD_LIBRARY_PATH enviroment variable, or by editing

* /etc/ld.so.conf. Make sure you have run ldconfig if that is

* required on your system.

* If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH

* to point to the correct configuration files

Это фрагмент из конфигура многих прог.

Пробовал и переменную фиксить и с бубном танцевать. Содержимое /etc/ld.so.conf:

/usr/kerberos/lib

/usr/X11R6/lib

/usr/lib/qt-3.0.5/lib

/usr/lib/sane

/usr/lib/wine

/usr/local/lib/glib

Чего делать короче?

Longobard

Приходиться конфигурить с опцией --disable-glibtest. То есть все пашет но все равно неприятно. Хочентся иметь систему без единой грабли, надежную и мощную. А вот такие вот грабли портят веь кайф.

Дмитрий Шурупов

Похоже, что у тебя просто в /usr/lib/pkgconfig/glib-2.0.pc (или local, или X11R6) прописана версия glib, которая не стоит на самом деле. Т.е., например, ты давно ставил 2.3.2, а потом некорректно ее удалил. Вот в pkg-config и осталась старая информация.