nixp.ru v3.0

18 января 2017,
среда,
11:02:52 MSK

DevOps с компанией «Флант»
Nuclear написал 21 апреля 2004 года в 16:43 (347 просмотров) Ведет себя как мужчина; открыл 27 тем в форуме, оставил 65 комментариев на сайте.

Добрый день. Столкнулся с интересной проблемой.

ПО: Mandrake 9.1

Штатное ядро, немного отконфигурированное.

Проблема заключаеться в том, что при загрузке системмы, а именно «Finding module dependencies» — системма останавливаеться. Такое явление не закономерно и может проявляться в 1/30 запусков или несколько раз в подряд. Зависимость от конкретных действий перед ребутом тоже не наблюдаеться. Не могу определить в чем скрыта причина.

anonymous

у меня такое было после сменя ядра с 2.2.х на 2.4.х. После установки новых module-init-tools всё прошло.

fly4life
Gen
у меня такое было после сменя ядра с 2.2.х на 2.4.х. После установки новых module-init-tools всё прошло.

У Nuclear’а проблемы со штатным ядром. Т.е. с ядром, которое идёт с дистрибутивом, а это значит, что module-init-tools там те, что надо, и проблема в другом…

Uncle Theodore

А что там в стартовых скриптах сразу после нахождения модульных зависимоcтей? Что-то подобное смутно припоминается, когда был бардак с монтированием файловых систем…

Good Luck,

UT

Nuclear

Версия module-init-tools не стандартная, так как я устанавливал ядро 2.6.1 и обновлял module-init-tools.

Насчет стартовых скриптов, сразу после нахождения зависимостей идут такие строки:

# tweak isapnp settings if needed.

if [ -n "$PNP" -a -f /proc/isapnp -a -x /sbin/sndconfig ]; then

/sbin/sndconfig —mungepnp >/dev/null 2>&1

fi

Еще обнаружил такие строки (в скрипте нахождения зависимостей)

if [ -L /lib/modules/default ]; then

INITLOG_ARGS= action «Finding module dependencies: » depmod -A default

else

INITLOG_ARGS= action «Finding module dependencies: » depmod -A

fi

Решил проверить. Так вот при первом условии, при выполнении команды «depmod -A default» возникает ошибка: Can’t open /lib/modules/default/modules.dep. Команда во стором условии выполняеться нормально «depmod -A».

Я не знаток bash, подскажите что означает условие » -L /lib/modules/default», возможно в нем кроеться ошибка.

П.С. Вообще смутно припоминаеться что ошибка начала появляться именно после переустановки module-init-tools. Мне кажеться что проблемма именно в этом.

anonymous

поставь нужную версию init-tools ( ту которая в документации к ядру написана) и всё будет ОК.

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.