nixp.ru v3.0

28 мая 2017,
воскресенье,
07:54:45 MSK

DevOps с компанией «Флант»
Z_Z написал 30 июля 2004 года в 16:28 (801 просмотр) Ведет себя неопределенно; открыл 9 тем в форуме, оставил 24 комментария на сайте.

Как сделать чтоб автоматически при загрузке Linux Mandrake (2,4,13-21) подымались сетевые интерфейсы eth0, eth1…

Чтоб после каждой перезагрузке не прописавть поновой..

ifconfig 192.168.0….. eth0 netmask 255.255.255.0 и т.д. ????

Дмитрий Шурупов

Добавить в загрузочные скрипты (что-то вроде /etc/init.d/rcS или /etc/rc.local).

У меня там:

ifconfig eth0 my_ip netmask my_netmask

route add -net my_net netmask my_netmask dev eth0

route add default gw my_gateway

Dreid
Z_Z
Как сделать чтоб автоматически при загрузке Linux Mandrake (2,4,13-21) подымались сетевые интерфейсы eth0, eth1…

Чтоб после каждой перезагрузке не прописавть поновой..

ifconfig 192.168.0….. eth0 netmask 255.255.255.0 и т.д. ????

Конкретно в Mandrake это делается так:

vi /etc/sysconfig/network-scripts/ifcfg-eth0

И прописываешь там что надо (какие параметры как там у них называются можешь посмотреть на примере ifcfg-lo или просто прочесть внимательно скрипт /etc/rc.d/init.d/network).

Кстати, не забудь убедиться, что этот серсис (network) у тебя вообще стартует :))

Z_Z

У меня в файле eth0 все прописано, но при загрузке Linux відается такое сообщение:

……………………………………………………………………………………………

Setting network parametrs: [ok]

Bringing up lookback interface: [ok]

egrep: ifcfg-eth0: No such file or directory

Bringing up interface eth1: [failed]

…………………………………………………………………………………………….

C eth0 было подобное eth1, но я с ним ковырялся и полычилось то, что получилось.Но я думаю, вернуться назад я смогу.

В чем проблемка здесь? Почему сетевые интерфейсы не подгружаются автоматически как lookback?

fly4life
Z_Z
У меня в файле eth0 все прописано

А что всё, если не секрет?

anonymous

файл ifcfg-eth0

#! /bin/bash

ifconfig eth0 192.168.40.5 netmask 255.255.255.0 up

файл ifup-eth0

DEVICE=«eth1»

IPADDR=«192.168.80.5»

NETMASK=«255.255.255.0»

ONBOOT=«yes»

BOOTPROTO=«bootp»

IPXNETNUM_802_2="»

IPXPRIMARY_802_2=«no»

IPXACTIVE_802_2=«no»

IPXNETNUM_802_3="»

IPXPRIMARY_802_3=«no»

IPXACTIVE_802_3=«no»

IPXNETNUM_ETHERII="»

IPXPRIMARY_ETHERII=«no»

IPXACTIVE_ETHERII=«no»

IPXNETNUM_SNAP="»

IPXPRIMARY_SNAP=«no»

IPXACTIVE_SNAP=«no»

Negative

а чего это вдруг

DEVICE=«eth1»

?

anonymous

перепутал:))

Это второй интерфейс.

Первый

DEVICE=«eth0»

IPADDR=«192.168.40.5»

NETMASK=«255.255.255.0»

ONBOOT=«yes»

BOOTPROTO=«bootp»

IPXNETNUM_802_2="»

IPXPRIMARY_802_2=«no»

IPXACTIVE_802_2=«no»

IPXNETNUM_802_3="»

IPXPRIMARY_802_3=«no»

IPXACTIVE_802_3=«no»

IPXNETNUM_ETHERII="»

IPXPRIMARY_ETHERII=«no»

IPXACTIVE_ETHERII=«no»

IPXNETNUM_SNAP="»

IPXPRIMARY_SNAP=«no»

IPXACTIVE_SNAP=«no»

Вообщем первый eth0 192.168.40.5

И второй eth1 192.168.80.5

fly4life

Гкхм… У тебя IPстатические. Так нафига ставить в конфиге опцию BOOTPROTO, да ещё и со значением «bootp»?

П.С. Протокол bootp вообще используют, в основном, для загрузки бездисковых станций ;)

konung

Hi!

Попробуй следующее.

в дире /etc/sysconfig/network-scripts/ создай 2 файла ifcfg-eth0 и ifcfg-eth1

(кстати, у тебя действительно 2 карточки?)

В ifcfg-eth0 должно быть

DEVICE=«eth0»

IPADDR=«192.168.40.5»

NETMASK=«255.255.255.0»

ONBOOT=«yes»

BOOTPROTO=static

В ifcfg-eth1

DEVICE=«eth1»

IPADDR=«192.168.80.5»

NETMASK=«255.255.255.0»

ONBOOT=«yes»

BOOTPROTO=static

Попробуй BOOTPROTO=static если конечно у тебя не настрополен

Bootstrap Protocol (BOOTP) service (RFC 951)

Ну и конечно /etc/init.d/network restart

konung
fly4life
Гкхм… У тебя IPстатические. Так нафига ставить в конфиге опцию BOOTPROTO, да ещё и со значением «bootp»?

Всетаки лучше ставить BOOTPROTO — так красивше :) Накрайняк можно так:

BOOTPROTO=none :)

Z_Z

Думаю сегодня у меня все получится:))

Z_Z

Ничего не получилось:(((

При загрузке выдается такое сообщение:

Setting network parameters: [ok]

Bringing up interface eth0: [failed]

Bringing up interface eth1: [failed]

Наверное, где-то еще надо чего-то прописать.:((

fly4life

Покажи что у тебя теперь в скриптах.

Z_Z

в /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=«eth0»

IPADDR=«192.168.40.5»

NETMASK=«255.255.255.0»

ONBOOT=«yes»

BOOTPROTO=static

В ifcfg-eth1

DEVICE=«eth1»

IPADDR=«192.168.80.5»

NETMASK=«255.255.255.0»

ONBOOT=«yes»

BOOTPROTO=static

Z_Z

может еще в скриптах ifup-eth0 и ifup-eth1 надо что-то подправить?

konung

Хм..

запусти 2 консоли

в первой

tail -f /var/log/messages

во второй

/etc/init.d/network restart

результаты в студию

Z_Z

Aug 5 20:07:16 linux — root[1695]: ROOT LOGIN ON vc/1

Aug 5 20:09:45 linux login(pam_unix)[1634]: session opened for user root by (uid=0)

Aug 5 20:09:45 linux — root[1634]: ROOT LOGIN ON vc/2

бЧЗ 5 20:10:29 linux network: Выключаеться интерфейс eth0: succeeded

бЧЗ 5 20:10:31 linux network: Выключаеться интерфейс eth1: succeeded

Aug 5 20:10:32 linux ifplugd[720]: Exit.

Aug 5 20:10:32 linux ifplugd[736]: Exit.

бЧЗ 5 20:10:34 linux network: Выключаеться интерфейс loopback: succeeded

бЧЗ 5 20:10:35 linux network: Устанавливаются параметры сети: succeeded

бЧЗ 5 20:10:37 linux network: Поднимаеться интерфейс loopback: succeeded

Aug 5 20:10:37 linux ifplugd[2083]: Using interface eth0/00:0C:29:F4:E5:6C with driver pcnet32 1.27b

Aug 5 20:10:37 linux ifplugd[2083]: ifplugd 0.13 successfully initialized, link beat not detected.

бЧЗ 5 20:10:37 linux network: Поднимаеться интерфейс eth0: failed

Aug 5 20:10:38 linux ifplugd[2100]: Using interface eth1/00:0C:29:F4:E5:76 with driver pcnet32 1.27b

Aug 5 20:10:38 linux ifplugd[2100]: ifplugd 0.13 successfully initialized, link beat not detected.

бЧЗ 5 20:10:38 linux network: Поднимаеться интерфейс eth1: failed

SIOCADDRT: No such device

Особенно меня смущает последняя строчка

Dreid
Z_Z
Aug  5 20:07:16 linux  -- root[1695]: ROOT LOGIN ON vc/1

Aug  5 20:09:45 linux login(pam_unix)[1634]: session opened for user root by (uid=0)

Aug  5 20:09:45 linux  -- root[1634]: ROOT LOGIN ON vc/2

бЧЗ  5 20:10:29 linux network: Выключаеться интерфейс eth0:  succeeded

бЧЗ  5 20:10:31 linux network: Выключаеться интерфейс eth1:  succeeded

Aug  5 20:10:32 linux ifplugd[720]: Exit.

Aug  5 20:10:32 linux ifplugd[736]: Exit.

бЧЗ  5 20:10:34 linux network: Выключаеться интерфейс loopback:  succeeded

бЧЗ  5 20:10:35 linux network: Устанавливаются параметры сети:  succeeded

бЧЗ  5 20:10:37 linux network: Поднимаеться интерфейс loopback:  succeeded

Aug  5 20:10:37 linux ifplugd[2083]: Using interface eth0/00:0C:29:F4:E5:6C with driver pcnet32 1.27b

Aug  5 20:10:37 linux ifplugd[2083]: ifplugd 0.13 successfully initialized, link beat not detected.

бЧЗ  5 20:10:37 linux network: Поднимаеться интерфейс eth0:  failed

Aug  5 20:10:38 linux ifplugd[2100]: Using interface eth1/00:0C:29:F4:E5:76 with driver pcnet32 1.27b

Aug  5 20:10:38 linux ifplugd[2100]: ifplugd 0.13 successfully initialized, link beat not detected.

бЧЗ  5 20:10:38 linux network: Поднимаеться интерфейс eth1:  failed

                              SIOCADDRT: No such device

Особенно меня смущает последняя строчка

Так. Он видит карточки, но не видит сети и не поднимает их из-за этого.

Это относительно новая для Мандрейка фича, в мане не упоминается, кажется.

Добавь MII_NOT_SUPPORTED=yes

Z_Z

Я уже запутался, что и куда добавлять:(((

Куда добавить эту строчку?

Dreid
Z_Z
Я уже запутался, что и куда добавлять:(((

Куда добавить эту строчку?

В ifcfg-eth[01]