nixp.ru v3.0

30 мая 2017,
вторник,
14:16:35 MSK

DevOps с компанией «Флант»
Lexion написал 6 октября 2004 года в 20:38 (244 просмотра) Ведет себя как мужчина; открыл 21 тему в форуме, оставил 51 комментарий на сайте.

Можно ли сделать что б Slackware 9 нормально поддерживал

RPM пакеты ?

fly4life

Ну, наверно, установить надо менеджер RPM пакетов ;)

А зачем? В слаке есть и свой менеджер пакетов.

Lexion

просто много хороших программ но они в РПМ ,

я пробую их ставить но подготовка к инсталяхе проходит , но прога не инсталируеться , мне сказали что слака плохо поддерживает

рпм

Master

Поставь checkinstall. Он то и будет на слаке рулить.

Lexion

а где взять этот checkinstall ?

И если его поставить будет нормальная поддержка РПМ ?

sky
Lexion
мне сказали что слака плохо поддерживает

рпм

Люди много херни всякой говорят =).

Шоб поставить rpm на слаке скорее всего просто нужно наплевать на зависимости (--nodeps в консоли)

Или быть умнее, и запустить rpm2tgz, а затем установить *.tgz пакет, тогда вообще всё будет сладко — как родной.

Lexion

пишу как раз rpm -ihv --nodeps и т.д ,

а оно не инсталлит

попробую rpm2tgz

Master
Lexion
пишу как раз rpm -ihv --nodeps и т.д ,

а оно не инсталлит

правильно, в слаке нету rpm

Вот к vector linux’у прикрутили его, вот только нафига?

а где взять этот checkinstall ?

На этом сайте есть поиск (который ищет и в разделе СОФТ), а также существует множество других поисковиков…

А если трудно поискать, то он находится тут: http://asic-linux.com.mx/~izto/checkinstall

ЗЫ: Еще в качестве конвертора можно попробовать заюзать Alien (http://kitenet.net/programs/alien)

sky
Master
правильно, в слаке нету rpm

Это какого … его нет, есть он:

bash-2.05b# ls /var/log/packages/|grep rpm

rpm-4.2.1-i486-3

ставится при установке системы, ну или с сидюка

Uncle Theodore
qwerty
Это какого … его нет, есть он:

Если посмотришь внимательно, увидишь, что он помечен как unsupported.

Однако, с rpm2tgz удается успешно ставить софт и из rpm, когда деваться некуда.

Good Luck,

UT

elPoohy
qwerty
Это какого … его нет, есть он:

bash-2.05b# ls /var/log/packages/|grep rpm

rpm-4.2.1-i486-3

ставится при установке системы, ну или с сидюка

Есть но!!!! он не работает 8-) А чтоб заработать надо качать исходники рпма последнего и компилить…. Тогда заработает 8-)

Только нафиг под слакой нужён рпм что make уже не моден ;-)

sky
son of a Pooh
Есть но!!!! он не работает 8-) А чтоб заработать надо качать исходники рпма последнего и компилить…. Тогда заработает 8-)

Только нафиг под слакой нужён рпм что make уже не моден ;-)

Ничерта качать не надо, работает из коробки….