nixp.ru v3.0

23 января 2017,
понедельник,
07:39:44 MSK

DevOps с компанией «Флант»
anonymous написал 11 ноября 2004 года в 23:59 (1272 просмотра) Ведет себя неопределенно; открыл 1814 темы в форуме, оставил 5575 комментариев на сайте.

Для начала, скажу что есть:

PIV-2666

Ati Radeon 9600 плюс дрова предпоследнии

Xorg-6.8.1

Оперативки 512мб

И вот хочу я посмотреть Armageddon с Брюсом Вилесом и Бен Афлеком,

запускаю kmplayer с xine-lib свеженькой версии, и о ужас… ааааааааа, фильм то притормаживает! 5 секунд нормально, рывок, 5 секунд нормально, рывок, а когда что то очень интересное и там цпецэффектов много, тогда рывки каждые 2 секунды, с mplayer еще хуже дела.

Что посоветуете?

fly4life

А не тормозит ли у тебя винт? Покажи hdparm /dev/hdX, где Х — буква жёсткого диска (именно диска, а не раздела на нём), с которого смотрится кино. А затем, hdparm -tT /dev/hdX.

anonymous

[root@localhost root]# hdparm /dev/hda

/dev/hda:

multcount = 16 (on)

IO_support = 0 (default 16-bit)

unmaskirq = 0 (off)

using_dma = 1 (on)

keepsettings = 0 (off)

readonly = 0 (off)

readahead = 256 (on)

geometry = 19457/255/63, sectors = 312581808, start = 0

[root@localhost root]# hdparm -tT /dev/hda

/dev/hda:

Timing buffer-cache reads: 1640 MB in 2.00 seconds = 818.90 MB/sec

Timing buffered disk reads: 110 MB in 3.04 seconds = 36.13 MB/sec

[root@localhost root]#

А даже если бы винт тормозил, у плеера нет такой функции чтобы кешировать хотябы по 3о мб фильма?

anonymous

скорее всего конфликт между Брюсом Вилесом и Бен Афлеком в одном фильме, попробуй запустить каждого в chroot’e плеером vlc.

Jaguar

У меня тоже фильмы тормозят и кажется именно из за диска

/dev/hda:

multcount = 16 (on)

IO_support = 1 (32-bit)

unmaskirq = 1 (on)

using_dma = 1 (on)

keepsettings = 0 (off)

readonly = 0 (off)

readahead = 256 (on)

geometry = 65535/16/63, sectors = 156301488, start = 0

[root@localhost jaguar]# /sbin/hdparm -tT /dev/hda

/dev/hda:

Timing buffer-cache reads: 496 MB in 2.01 seconds = 246.56 MB/sec

Timing buffered disk reads: 20 MB in 3.18 seconds = 6.29 MB/sec

Genie

сравнивайте, особенно с выводом второй команды

$ hdparm /dev/hda
/dev/hda:
 multcount    = 16 (on)
 IO_support   =  1 (32-bit)
 unmaskirq    =  1 (on)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 readahead    = 256 (on)
 geometry     = 16383/255/63, sectors = 60022480896, start = 0
$ hdparm -i /dev/hda
/dev/hda:
 Model=ST360014A, FwRev=3.04, SerialNo=3JV0X78Z
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs RotSpdTol>.5% }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
 BuffType=unknown, BuffSize=2048kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=117231408
 IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5
 AdvancedPM=no WriteCache=enabled
 Drive conforms to: ATA/ATAPI-6 T13 1410D revision 2:
 * signifies the current active mode
$ hdparm -Tt /dev/hda
/dev/hda:
 Timing cached reads:   432 MB in  2.02 seconds = 214.32 MB/sec
 Timing buffered disk reads:  102 MB in  3.03 seconds =  33.68 MB/sec
Jaguar

Отличие в выводе второй команды (hdparm -i /dev/hd), у меня он пишет:

«Drive conforms to: device does not report version:».

Это не есть хорошо?

anonymous

Я так думаю дело в видео системе, не успевает почемуто обрабатывать, какие тесты можно провести, чтобы узнать может ли мое видео воспроизводить фильмы без тормозов?

Genie

проверить видео — glxgears. не совсем, правда, по теме, но, раз сказано, что драйвера установлены, то — сойдёт.

далее. настройки mplayer в студию!

мои вот, к примеру, такие:

$ cat ~/.mplayer/config
# Write your default config options here!
ao=alsa,oss:/dev/adsp1,oss:/dev/dsp1,oss:/dev/dsp
vo=xv,gl,x11,sdl,vesa

если видео играет на второй видео, на которой ни xv, ни gl не работают, указываю mplayer -vo x11 ….. Правда, при этом моя системка занята на 30-40%.

Longobard

schedtool -I -e mplayer blablablabla

Не тормозит нифига :) Правда нужно ядрышко, поддерживающее SCHED_ISO (например ck, nitro).

У меня система слабее твоей.

mplayer пересобрать пробовал?

anonymous

Я xine использую, а что mplayer лучше? если да то чем

anonymous

Кстати у меня radeon 9600, ati не делает поддержки gl под xorg 6.8.1

ivan

Поставь Mplayer не пожалеешь. У меня видюха гораздо слабее твоей, но еще ни один фильм не тормозил. Ну если не поможет, то попробуй пересобрать Mplayer там опций хватает по этому поводу. Можешь попробовать

запускать фильм с опцией framedrop

Genie
Не тормозит нифига :) Правда нужно ядрышко, поддерживающее SCHED_ISO (например ck, nitro).

У меня система слабее твоей.

mplayer пересобрать пробовал?


- это мне? :))

дело в том, что ты не обратил внимания, какая именно стоит 2ая видео….

вот выдержка из /etc/X11/XF86Config-4 о ней:

Section "Device"
        Identifier  "PCI 3dfx Voodoo Rush"
#       Driver      "apm"
        Driver      "vesa"
        VendorName  "Alliance Semiconductor"
        BoardName   "ProMotion AT3D"
        BusID       "PCI:1:9:0"
EndSection

используется драйвер vesa, так как apm вешает систему.

если же проигрывание запустить на основной видео, то 9 mplayer-ов одновременно, проигрывающих разные фильмы не особо нагружают систему (15-20-25%).

Longobard
- это мне? :))

Это автору треда.

anonymous

тоже самое(при просмотре фильмов было сплошное слайдшоу . про 3Д молчу уже) было на АТИ 9100ПРО 64МБ .

сменил на НВИДИА GF 2MX 32MB — прошло .

кстати по поводу hdparm … c3 хоть поставь и -Х69 . а ?

anonymous

Что xine, что mplayer, все равно одно и тоже, примерно каждые 15 сек,происходит дергание графики, а иногда и графика и звук дергаются, вообще не понятно почему , может дрова такие?

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.