nixp.ru v3.0

27 мая 2017,
суббота,
05:33:15 MSK

DevOps с компанией «Флант»
Аватар пользователя aivs
aivs написал 24 марта 2005 года в 22:13 (761 просмотр) Ведет себя как мужчина; открыл 114 темы в форуме, оставил 292 комментария на сайте.

Хочу установить прогу, а она мне выдает такое сообщение:

checking for pkg-config… /usr/bin/pkg-config

checking for x11 xext… Package x11 was not found in the pkg-config search path.

Perhaps you should add the directory containing `x11.pc'

to the PKG_CONFIG_PATH environment variable

No package 'x11\′ found

configure: error: Library requirements (x11 xext) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

[root@localhost xkbfile]#

make install для x11 сделал, он кстати у меня ради экперемента лежит в /opt/gnome2

чтоже мне сделать чтобы прога увидела что x11 установлен?

fly4life


PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/path/to/dir/with/lib
export PKG_CONFIG_PATH

где /path/to/dir/with/lib — путь до директории с нужной тебе программой/библиотекой.

Master
fly4life

PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/path/to/dir/with/lib
export PKG_CONFIG_PATH

где /path/to/dir/with/lib — путь до директории с нужной тебе программой/библиотекой.

Точнее до директории где лежит `x11.pc'

aivs

спсибо