nixp.ru v3.0

19 октября 2017,
четверг,
21:22:46 MSK

DevOps с компанией «Флант»
kraskanik написал 1 мая 2005 года в 07:01 (360 просмотров) Ведет себя неопределенно; открыл 2 темы в форуме, оставил 1 комментарий на сайте.

Здравствуйте, помогите решить проблему. Есть SuSE 9.2, модем ZyXel_Omni_56K_Uno(USB). Проблема в том, что не могу выйти в Инет. Модем определяется, снимает трубку, звонит, болтает с провайдером, цепляется, молчит пару минут и соединение разрывается. В журнале пишет: SuSE Meta pppd (smpppd-ifcfg), Version 1.50 on linux. Status is: disconnected trying to connect to smpppd connect to smpppd Status is: disconnected Status is: connecting pppd[0]: Plugin passwordfd.so loaded. pppd[0]: Removed stale lock on ttyACM0 (pid 5202) pppd[0]: --> WvDial: Internet dialer version 1.54.0 pppd[0]: --> Initializing modem. pppd[0]: --> Sending: ATZ pppd[0]: ATZ pppd[0]: OK pppd[0]: --> Sending: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 pppd[0]: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 pppd[0]: OK pppd[0]: --> Sending: ATM1 pppd[0]: ATM1 pppd[0]: OK pppd[0]: --> Modem initialized. pppd[0]: --> Sending: ATDT25500 pppd[0]: --> Waiting for carrier. pppd[0]: ATDT25500 pppd[0]: CONNECT 460800/V.92 50666/V44 pppd[0]: --> Carrier detected. Waiting for prompt. pppd[0]: First XXXXX Internet Provider pppd[0]: User Access Verification pppd[0]: Username: pppd[0]: --> Looks like a login prompt. pppd[0]: --> Sending: XXXXX pppd[0]: XXXXX pppd[0]: Password: pppd[0]: --> Looks like a password prompt. pppd[0]: --> Sending: (password) pppd[0]: % Authentication failed. pppd[0]: Username: pppd[0]: --> Looks like a login prompt. pppd[0]: --> Sending: XXXXX pppd[0]: XXXXX pppd[0]: Password: pppd[0]: --> Looks like a password prompt. pppd[0]: --> Sending: (password) pppd[0]: % Authentication failed. pppd[0]: Username: pppd[0]: --> Looks like a login prompt. pppd[0]: --> Sending: XXXXX pppd[0]: XXXXX pppd[0]: --> Don’t know what to do! Starting pppd and hoping for the best. pppd[0]: Serial connection established. pppd[0]: Renamed interface ppp0 to modem0 pppd[0]: Using interface modem0 Status is: connecting pppd[0]: Connect: modem0 <--> /dev/ttyACM0 pppd[0]: Hangup (SIGHUP) pppd[0]: Modem hangup pppd[0]: Connection terminated. Status is: disconnecting pppd[0]: Terminating on signal 15. Status is: disconnecting Status is: disconnected pppd[0] died: A modem hung up the phone (exit code 16) Подскажите в чем дело, я так понимаю, что как будто бы неверная аутонтификация, но логин и пароль ввожу верно (тот же пароль и логин ввожу в windows и все проходит нормально). Если кто знает в чем дело прошу писать на kraskanik@mail.ru Заранее благодарен.

Genie

<font size=«-2»>(хммм. Enter-ов после копирования наставить ьбыло сложно?)</font>

судяпо этому:

pppd[0]: --> Sending: ATDT25500

pppd[0]: --> Waiting for carrier.

pppd[0]: ATDT25500

pppd[0]: CONNECT 460800/V.92 50666/V44

pppd[0]: --> Carrier detected. Waiting for prompt.

pppd[0]: First XXXXX Internet Provider

pppd[0]: User Access Verification

pppd[0]: Username:

pppd[0]: --> Looks like a login prompt.

pppd[0]: --> Sending: XXXXX

pppd[0]: XXXXX

pppd[0]: Password:

pppd[0]: --> Looks like a password prompt.

pppd[0]: --> Sending: (password)

pppd[0]: % Authentication failed.

может надо в chat-скрипте соединения добавить строки:

'Username:' 'твой_login'
'Password:' 'твой_пароль'

на всякий случай, попробуй при помощи команды minicom — пошли модему команды инициализации, дозвоня, и погляди, будет ли это работать — если послать логин/пароль ручками.

а там уже и видно будет.

anonymous

У меня в том же дистрибутиве и с тем же модемом прблем не было…

Genie
У меня в том же дистрибутиве и с тем же модемом прблем не было…

тут не с модемом и не дистром проблема… а подключением к конкретному определённому провайдеру, если т ыне заметил

Genie

отвечу тут на личное сообщение:

Я догадываюсь, что здесь проблема, возможно, с выходом на провайдера, но меня больше интересует как все настроить, чтоб работало.

если честно, то тут может быть ещё и проблема с самим pppd

как-то тут уже было обсуждение, связанное с pppd и SuSE 9.2 кажется, это было проблемой у Vima)

в общем, действия на попробовать:

грузишь винды

ставишь логировать общение с модемом

соединяешься

смотришь лог.

особенно что там после CONNECT идёт

потому как тут, скорее всего, дело в различии процесса авторизации

к сожалению, я уже очень давно не пользовался модемами в винде, так что процесс уже забыл напрочь.

поэтому — искать различия в процессе мне сложно :(

serzhinio

Стоит 10,1 версия мандрейка и суть проблемы в следующем

Захожу в инет через kppp — часики идут, вроде все нормально, а вот страницы почему то не загружаются, хотя вроде как и прокся прописана нормально (под Knoppix все без проблем летает).

kppp выдает следующий лог

May 1 22:17:48 localhost pppd[8564]: pppd 2.4.2 started by sergey, uid 501

May 1 22:17:48 localhost pppd[8564]: Using interface ppp0

May 1 22:17:48 localhost pppd[8564]: Connect: ppp0 <--> /dev/ttyS0

May 1 22:17:51 localhost pppd[8564]: Remote message: Success

May 1 22:17:51 localhost pppd[8564]: PAP authentication succeeded

May 1 22:17:52 localhost pppd[8564]: Received bad configure-ack: 1a 04 78 00 18 04 78 00 15 03 2f

May 1 22:17:52 localhost pppd[8564]: local IP address xxx.xx.xxx.107

May 1 22:17:52 localhost pppd[8564]: remote IP address xxx.xx.xxx.109

May 1 22:17:52 localhost pppd[8564]: primary DNS address xxx.xx.xxx.99

May 1 22:17:52 localhost pppd[8564]: secondary DNS address xxx.xx.xxx.99

May 1 22:18:03 localhost pppd[8564]: Received bad configure-ack: 1a 04 78 00 18 04 78 00 15 03 2f

May 1 22:18:13 localhost pppd[8564]: Received bad configure-ack: 1a 04 78 00 18 04 78 00 15 03 2f

May 1 22:18:16 localhost pppd[8564]: Received bad configure-ack: 1a 04 78 00 18 04 78 00 15 03 2f

May 1 22:18:19 localhost pppd[8564]: Received bad configure-ack: 1a 04 78 00 18 04 78 00 15 03 2f

May 1 22:18:22 localhost pppd[8564]: CCP: timeout sending Config-Requests

May 1 22:26:37 localhost pppd[8564]: Hangup (SIGHUP)

May 1 22:26:37 localhost pppd[8564]: Modem hangup

May 1 22:26:37 localhost pppd[8564]: Connection terminated.

May 1 22:26:37 localhost pppd[8564]: Connect time 8.9 minutes.

May 1 22:26:37 localhost pppd[8564]: Sent 11954 bytes, received 960 bytes.

May 1 22:26:37 localhost pppd[8564]: Connect time 8.9 minutes.

May 1 22:26:37 localhost pppd[8564]: Sent 11954 bytes, received 960 bytes.

May 1 22:26:37 localhost pppd[8564]: Exit.

Подскажите люди добрыя чего исправить можно дабы под Линуксой в инет лазить.

Genie

гугль://"Received bad configure-ack:«+»1a 04 78 00 18 04 78 00 15 03 2f» ???