nixp.ru v3.0

23 мая 2017,
вторник,
00:31:31 MSK

DevOps с компанией «Флант»
BADC0DEh написал 25 ноября 2005 года в 19:08 (277 просмотров) Ведет себя как мужчина; открыл 20 тем в форуме, оставил 45 комментариев на сайте.

Сразу прошу прощения, не пинайте ногами :)

1. Как выйти из графической оболочки (КДЕ) в консоль, перезапустить Ctrl-Alt-BackSpase, знаю,а вот чтобы из консоли драйвера видяхи на установку запустить.

2. У меня 2 моника, я в федоре попробовал SystemSettings->Display->Два Монитора

Всё настроил, перезапустил KDE, написало, что не может заупститься с текущими настройками иксов.

3. В /etc/X11/xorg.conf настроил себе клаву и переключения, как надо, а не переключается :(.

Dr. Evil
1. Как выйти из графической оболочки (КДЕ) в консоль, перезапустить Ctrl-Alt-BackSpase, знаю,а вот чтобы из консоли драйвера видяхи на установку запустить.

для простого входа в консоль из Иксов — Ctrl+Alt+F1

если хочешь поставить драйверы для видео из консоли — Alt+F2, а потом вводишь команду init 3, enter (под рутом).

3. В /etc/X11/xorg.conf настроил себе клаву и переключения, как надо, а не переключается

согласись, что при корректной настройке все бы работало…

давай кусок конфа!

дистрибутив какой?

BADC0DEh

Вот заветный файлик… Я его сравнивал с такой же федорой на другом компе, у меня они через свич подключены к одной клаве и монику, подскажите плз, что надо заменить чтобы 2 монитора подрубить? Я могу переключать раскладки только окошечком в «трее» ru/us и не сочетанием клавиш, а мышкой приходится шпилить, и раскладка совсем не winkeys. Такое впечетление, что файл xorg.conf просто игнорируется.

Кстати,

если хочешь поставить драйверы для видео из консоли — Alt+F2, а потом вводишь команду init 3, enter (под рутом).

эта штука делает с компом что-то не понятное — вижу только чёрный экран и всё.

[root@badc0deh qwerty]# cat /etc/X11/xorg.conf
# Xorg configuration created by system-config-display
Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
Section "Files"
# RgbPath is the location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "unix/:7100"
EndSection
Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "dri"
EndSection
Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#       Option  "Xleds"         "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#       Option  "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#       Option  "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#       Option  "XkbModel"      "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#       Option  "XkbLayout"     "de"
# or:
#       Option  "XkbLayout"     "de"
#       Option  "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#       Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#       Option  "XkbOptions"    "ctrl:nocaps"
#
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us,ru(winkey)"
        Option      "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
EndSection
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "yes"
EndSection
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Samsung SyncMaster 710N/177N/CX711N/CX701N"
        DisplaySize  340        270
        HorizSync    30.0 - 81.0
        VertRefresh  56.0 - 75.0
        Option      "dpms"
EndSection
Section "Device"
        Identifier  "Videocard0"
        Driver      "nv"
        VendorName  "Videocard vendor"
        BoardName   "NVIDIA GeForce 6600"
EndSection
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     16
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection
Section "DRI"
        Group        0
        Mode         0666
EndSection
[root@badc0deh qwerty]#

Извините за сумбурность изложения, по-другому мыслить не умею :)

Sasha2

Вот что касается переключения клавиатурой, то ты его и не получишь по Alt-Shift при помощи переключателя от KDE Control Center. Для этого надо указать, что группу у тебя переключает Shift (один, правый или левый, а затем при настройках клавишных указателей указать Alt+Shift (читаться будет Alt+ISO_Next_Group)). Однако такая практика не есть хорошо. Это дурные привычки, которые накоплены нами от частого пользования Windows. Рекомендую пользоваться правым Ctrl. КЛавиша действительно как бы приспособлена для этой цели. Для другого она просто не нужна.

BADC0DEh

Как я понял, мне надо чтобы KDE Control Center брал настройки клавы из моего xorg.conf и всё в моей жизни будет хорошо. Как ему об этом намекнуть? А переключение группы и раскладки это одно и тоже? Кстати, у меня свич стоит, так что на контрол биндить что-то говноплан.

Sasha2

Да понимаешь в чем дело, в X переключает действительно Ctrl-Shift, а в KDE это происходит с использованием клавиши ISO_NEXT_GROUP (которую ты должен назначить ранее, если конечно не хочешь пользоваться какой-либо экзотической комбинацией клавиш). Но как только ты назначил ее, например клавише правой Ctrl, все считай, что клавиши правого Ctrl у тебя в системе нет, а есть клавиша ISO_NEXT_GROUP. Хорошо это или плохо, не знаю, но так KDE устроено, а вопрос этот уже задается 1001 раз всеми, кто переходит с Win на Lin. Я его тоже в свое время задавал, но лучше, настроить клаву на тот режим, который тебя больше устраивает, исходя из тех, которые есть. А затем в процессе работы пойменшь сам, как настроить в KDE переключение Ctrl+Shift или Alt+Shift, только сразу же (во всяком случае со мной) поймешь, что на самом деле это нафиг не нужно.

Dr. Evil

флажки, которые ты вдишь в трее — это раскладка KDE (настройка в KDE Control Center --> Региональные и специальные возможности --> Комбинация клавиш).

эта штука делает с компом что-то не понятное — вижу только чёрный экран и всё.

это Fedora? если да, то это мне известная бага! черт знает, как это лечить!

BADC0DEh

Vot priplqli taziki… :)

Teper' translitom :))

Pochital Fedora’s help. Tam napisano, chto

Замечание

Чтобы сделать вашу конфигурацию XFree86 рабочей, вы должны отключить параметры Включить раскладки клавиатуры во вкладке раскладок и Включить расширения xkb во вкладке параметров Xkb (для последнего такой же эффект может быть достигнут если отключtн Сбросить старые параметры и никакие параметры xkb не установлены).

help, vstavliat' mogu.

Koroche poproboval vqkluchit' ne pomoglo. :( Pochemu ne znaju.

Vkluchil Включить раскладки клавиатуры v tree vizhu «err» vmesto ru||en, kogda 1 raskladka, tozhe tak. Koroche ne znaju chego teper' probovat’.

Pri navedenii pishet po-russki: «Oshibka smenq raskladki klaviaturq na ru»

zacenite nashol v yandex:

http://www.linux.ru/forum/index.php?t=msg&goto=154362&rid=0&S=bbd011de537a602084e0b169bfeb6dadt=msg&goto=154362&rid=0&S=bbd011de537a602084e0b169bfeb6dad

BADC0DEh

Короче, я могу снова писать на русском… Переключаюсь командой setxkbmap ru(набрать сюда winkeys не вышло :(), обратно пришлось копировать и вставлять в консоль, чтобы набрать setxkbmap us. Война и немцы…

Кстати, я тоже сегодня пообновлял Федору, может из-за этого и поплатился

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121016#c4

BADC0DEh

Всем привет. У меня на ночь были включены апдейты yum, проапдейтило всё, перезагрузил. КДЕ загрузилось :) Сеть не фачит. Раскладки не переключаются :) Мясо :-Е

BADC0DEh
BADC0DEh
Всем привет. У меня на ночь были включены апдейты yum, проапдейтило всё, перезагрузил. КДЕ загрузилось :) Сеть не фачит. Раскладки не переключаются :) Мясо :-Е

S set’ju sam durak. Skachalos' novoje jadro, nuzhno bilo drova dlia vidiahi votknut’.

Sasha2

Ну что касается ошибок переключения раскладок, ты укажи опцию

Option «XkbRules» «xorg»

Но может быть не xorg (надо зайти в каталог Rules для твоих X и посмотреть как называется этот файл, может он называется не xorg, а xfree86, а xorg просто ссылка (ну или должна быть ссылка на него, а ее забыли добавить).

И еще просмотреть надо этот файл то, и указывать может быть не alt_ahift_toggle, а так как этот переключатель ообозван в этом файле. Ну грубо говоря, смотри не то, что на бумажке написано, а то, что есть на самом деле.

cyb3rpunk

BADC0DEh, если честно, я вообще не представляю, зачем тебе кдеешный переключатель, отруби его и не парься :)

BADC0DEh

Sasha2, спасибо, помогло, похоже строчка Option «XkbRules» «xorg» помогла.

А на счёт каталого Rules я не совсем понял, это /usr/X11R6/lib/X11/xkb/rules он?

Там файлы xfree86 ссылаются на xorg. Это имелось в виду?

cyb3rpunk, теперь кдешный переключатель отрублен :)

И всё-таки, как же мне перейти в консоль без KDE? Чтобы дрова для видяхи поставить? У меня FedoreCore IV

Мужики, ипануться! Я настроил для своего GeForse6600 два моника. Я счастлив.

Sasha2

Да это.

Только я не могу ведь точно знать и помнить про то, каким этот каталог явлется в каждом дистрибутиве.

BADC0DEh

Ещё раз спасибо.

Кстати, у меня не получилось подключить два монитора, из-за того, что при изменении xorg.conf программой там не правильно прописывались драйвера

Section "Device"
        Identifier  "Videocard0"
        Driver      "nv"  # а надо было "nvidia"

Так что после использования в kde

System Settings -> Display -> Два монитора

Следует проверить xorg.conf, правильно ли там всё ;)