nixp.ru v3.0

20 января 2017,
пятница,
23:18:27 MSK

DevOps с компанией «Флант»
Ping_Win написал 11 апреля 2006 года в 00:46 (266 просмотров) Ведет себя неопределенно; открыл 73 темы в форуме, оставил 102 комментария на сайте.

Оооох. Здрасьте, люди добрые.

Я уже измучался совсем: есть у меня IDE/SATA/RAID-контроллер, который именуется

VIA VT6421. Есть у меня дистрибутив ASP10(есть и другие). Нужен номальный драйвер для этой железяги. Дело в том что на сайте VIA почему-то валяется одно старье, т.е. под старые дистры типа RH9, Mandrake 9.2 и т.д. Все скомпиленные модули имеют расширение .o и расчитаны на ядра 2.4. Есть также дрова под Fedora4, которого у меня к сожалению нет. В состав этих дров входит скомпиленный модуль sata_via.ko и патч к ядру. Модуль подгрузить не удается, ругается что Invalid module format и т.д. А применение патча к ядру на тоже безуспешное (из 7 заплат, 3 ошибки).

Пробовал проделывать операции на ASP и Gentoo, везде без успеха.

Вопросы такие:

1. Можно ли где-нить найти номальные исходники дров? Почему на сайте производителя одно старье, неужели так модно?

2. Возможно ли теоретически избежать ошибки подгрузки модуля или наложения патча если перейти на более новое ядро? (у меня везде 2.6.9)?

3. Посоветйте вообще хоть что-нибудь, срочно надо настроить этот контроллер. Неужели придется покупать дистр Федоры или пересажжваться на старый RH? Ни того ни другого не хочется.

Спасибо огромное

Dmitry Ivanov

я вроде давал в соседнем треде рекомендацию….

Ping_Win

Да я ужо весь гугл облазил, а результата нет.

anonymous
Ping_Win
Да я ужо весь гугл облазил, а результата нет.

У нас что, разные гугли?

http://lwn.net/Articles/111222/

http://lwn.net/Articles/122290/

http://linuxmafia.com/faq/Hardware/sata.html

http://www.ussg.iu.edu/hypermail/linux/kernel/0512.1/0949.html

Ping_Win

Огромнейшее человеческое СПАСИБО! Еееее. Всё работает.

Ударился в настройку LVM!

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.