nixp.ru v3.0

19 октября 2017,
четверг,
03:12:57 MSK

DevOps с компанией «Флант»
Longobard написал 12 августа 2006 года в 19:24 (440 просмотров) Ведет себя как мужчина; открыл 291 тему в форуме, оставил 2499 комментариев на сайте.

На ровном месте (чесслово, ничего не трогал! Просто ребутнулся, штатно, через reboot.) появился такой косяк:

в иксах пропадает текст, причем пропадает он абсолютно случайно. Проведешь по нему мышкой — появляется, потом снова пропадает. Работать невозможно.

Вот скриншот:

http://longobard.org.ru/misc/1.png

я тут мышкой по экрану повозюкал, часть текста появилась. В заголовках оперных табов он так и не появился. Вот пишу этот пост — он то исчезает, то появляется.

Дрова попробовал обновить, не помогло. Иксы пересобрал, потом обновил до последних — не помогло. В логе закрузки иксов такая надпись:

(EE) ============= WARNING WARNING WARNING WARNING =============

(EE) This server has a video driver ABI version of 1.0 but this

(EE)     driver is designed to work with versions before 1.0.  The

(EE)     driver will continue to load, but may behave strangely.

(EE)     Please check http://www.nvidia.com/ for driver updates or

(EE)     downgrade to an X server with a supported driver ABI.

(EE) ===========================================================

Хз, была ли она раньше.. Но сейчас есть. Возможно, она поможет найти причину.

Пересобрал заодно kdebase (ибо в konsole вобще весь текст пропал напрочь), пересобрал qt, gtk, xorg-server и xorg-x11, fluxbox Никакого результата.

В GTK программах (напр. xemacs) все норм, в xterm тоже.

Что делать? Работать в таких условиях невозможно :( Помогите please!

Longobard

Версии софта:

xorg-server-1.1.1

xorg-x11-7.1

дрова nvidia-8762

fluxbox-1.0-rc2-r2

qt 4.1.2

Genie

что ж тебе на старом софте не сиделось?

тут вот тебе ясно описывется, что и как. в общем, возвращай Xorg-7.0 обратно.

либо живи на драйвере nv и жди нового драйвера от nVidia

rgo
Longobard
Версии софта:

xorg-server-1.1.1

xorg-x11-7.1

дрова nvidia-8762

fluxbox-1.0-rc2-r2

qt 4.1.2

гыгы. у меня таже байда. облазал форум nvidia, там написано, что нехер запускать дрова нвидии на xorg-7.x, ибо дрова его ещё не поддерживают. Но, если помучаться, то я уверен можно всё сделать тип-топ. Дело в том, что только какие-то определённые шрифты не рисуются. Я не вникал подробнее, но например, nixp.ru у меня рисуется нормально, а на других форумах, русский текст нормально, а английский именно так как ты описываешь. в wine вообще ничего не рисуется, я вендовые проги на framebuffer’е запускаю.

rgo
Longobard
На ровном месте (чесслово, ничего не трогал! Просто ребутнулся, штатно, через reboot.) появился такой косяк:[...]

может ты всё-таки что-то обновлял до ребута? Ну там за пару суток до того? Забыл проверить, а после ребута это просто вылезло. Со мной так было пару раз.

Longobard

откатил иксы до 7.0, все стало норм в opera и прочих прогах, а вот в konsole текста как не было, так и нету :) Чего делать? konsole пересобирать пробовал, не помогает.

Genie
что нехер запускать дрова нвидии на xorg-7.x, ибо дрова его ещё не поддерживают.

на самом деле не поддерживают 7.1 — как раз из-за ABI. 7.0 нормально работает…

откатил иксы до 7.0, все стало норм в opera и прочих прогах

ну, уже хорошо. ;)

а вот в konsole текста как не было, так и нету :) Чего делать?

указывать шрифты ему не прообвал?

может действительно, какие шрифты не работают (семейтво там или вообще отдельный тип)?

тут, скорее, может надо шрифтовые библиотеки пересобрать.. pango, fontconfig…

Longobard

Кстати нашел текст, который и в опере косячит:

http://rsdn.ru/Forum/Message.aspx?mid=2055072 (первое сообщение).

Так что дело действительно в шрифтах….

Longobard

Вобще по-хорошему можно откатить иксы до 6.8, но очень геморно. С переходом на 7.0 они стали модульные, так что теперь при попытке поставить 6.8 натыкаюсь на туеву хучу блоков :(

Longobard

pango и fontconfig пересобрал, не помогло. Что еще пересобрать?

rgo
Longobard
pango и fontconfig пересобрал, не помогло. Что еще пересобрать?

а разве панго в кде используется?

мне кажется, что ttf шрифты рисуются нормально. наверное, стоит freetype попробовать.

rgo

ык. есть специальная программка xfontsel. в ней тоже шрифты глючат, но не все, а некоторые. это способ найти глючные и выкинуть их нафиг.

rgo

судя по всему, проблема в фонтах b&h. но если их запретить в fonts.conf, то мозилла, сцуко, не запускается. надо будет подумать как бы ему так сказать, что за фонты использовать вместо b&h.

Genie

нуу. попробуйте xfs-tt поставить… (XFontServer-Truetype)

и подключтаь шрифты от него…

ps: чесслово, в который раз уже рад тому, что не гоняюсь за свежайщим софтом ;) (ну, кроме ядра, разве что, да и то, последнее время забил даже на это…)

Longobard
Genie
ps: чесслово, в который раз уже рад тому, что не гоняюсь за свежайщим софтом ;) (ну, кроме ядра, разве что, да и то, последнее время забил даже на это…)

Да дело было так:

захотел я обновить фаерфокс, программерское любопытство возобладало (посмотреть чего там нового в новой версии). А новый фф почему-то захотел седьмые иксы (которые модульные). Я удивился, какая ему разница какие у меня иксы. Но поставил. Видимо, рестартовать иксы мне было лень. И вот после ребута последовал запуск новых иксов и куча геморроя с этим связанного :(

rgo
Genie
ps: чесслово, в который раз уже рад тому, что не гоняюсь за свежайщим софтом ;) (ну, кроме ядра, разве что, да и то, последнее время забил даже на это…)

мне проще мучаться от переизбытка багов в софте, чем от неудовлетворённого любопытства :)

Longobard

Ценой невероятных усилий и не без вазелина удалось воткнуть иксы 6.8 вместо модульных 7.0. Уф! :)