nixp.ru v3.0

19 октября 2017,
четверг,
21:21:01 MSK

DevOps с компанией «Флант»
Аватар пользователя Toha
Toha написал 22 октября 2006 года в 00:28 (588 просмотров) Ведет себя неопределенно; открыл 23 темы в форуме, оставил 68 комментариев на сайте.

Взгромоздил я на фрибзду вебмина и возрадовался (не надо только воплей «настоящий сисадмин все через консоль делает!») Но не долго.

захотел я чтоб трафик мой шифровался (дабы хитрый, злобный хацкер не подсмотрел логины-пароли) и тут облом. Почитал инет пишут:

Test the SSL install

If the command perl -e 'use Net::SSLeay' doesn’t output any error message, then the SSL support that Webmin needs is properly installed.

Ну попробовал я перловую команду, все нормально. Но нету https.Облом

позаморачивался нифига не получаеться. По старой,доброй виндовой традиции пошел путем «Удалил вебмину-поставил заново»

При установке меня спросили а не хочу ли я случайно поддержку SSL? я блин как дурак обрадовался и говорю: Вах!Канэшна хочу!

Скрипт ответил Ок, без проблем все будет!

запустил я вебмина полез через https а там жирная такая фига!

Полазил я по логам нарыл вот это при установке было:

Use SSL (y/n): y

# кучка строк пропущена

Attempting to start Webmin mini web server..

Can’t locate auto/Net/SSLeay/autosplit.ix in @INC (@INC contains: /usr/local/lib/webmin /usr/local/lib/perl5/site_perl/5.6.2/mach /usr/local/lib/perl5/site_perl/5.6.2 /usr/local/lib/perl5/site_perl /usr/local/lib/perl5/5.6.2/BSDPAN /usr/local/lib/perl5/5.6.2/mach /usr/local/lib/perl5/5.6.2 .) at /usr/local/lib/perl5/5.6.2/AutoLoader.pm line 146.

at /usr/local/lib/perl5/site_perl/5.6.2/mach/Net/SSLeay.pm line 70

..done

*****************************************************************

Webmin has been installed and started successfully. Use your web

browser to go to

https://myserver.mydomain:myport/

Однако все как раньше https://myserver.mydomain:myport/ -молчит как партизан, зато http://myserver.mydomain:myport/ замечательно работает.

Я так понимаю модулю SSLeay.pm чего-то не хватает однако время к вечеру на пальцах мозоли от клавы, гугль уже в лицо меня узнает а мыслей чего не хватает (про мозги версию не предлагать) и где это взять нету.

Toha

Нифига не понимаю обновил версию вебмины с 1.180 до 1.300 из него самого, и вуаля все заработало… Может кто нибудь мне объяснит что произошло??

(обидно сутки культивирования гемморроя, а все оказалось так просто…)

Genie

ну так оно и бывает.. имеешь долгий и безрезультатный… а в конце — вот оно, банальное решение…

абыдна, да?

fly4life
Toha
Нифига не понимаю обновил версию вебмины с 1.180 до 1.300 из него самого, и вуаля все заработало… Может кто нибудь мне объяснит что произошло??

(обидно сутки культивирования гемморроя, а все оказалось так просто…)

Видимо, в 1.180 на предмет SSL что-то было отломано. Ничего удивительного ;).