nixp.ru v3.0

21 января 2017,
суббота,
03:13:54 MSK

Аутсорсинг Linux с компанией «Флант»
caleb написал 20 декабря 2006 года в 11:43 (306 просмотров) Ведет себя неопределенно; открыл 17 тем в форуме, оставил 27 комментариев на сайте.

Что делать, когда при инсталляции пакет говорит «sh is needed» для этого пакета?

Heavy

Для какого пакета? Если нужен sh то поставь его

semka

Эээ. А sh это не posix стандарт?

fly4life
caleb
Что делать, когда при инсталляции пакет говорит «sh is needed» для этого пакета?

Дистрибутив какой? Что за пакет ставишь?

fly4life
semka
Эээ. А sh это не posix стандарт?

Всмысле?

Steck

ЭЭээ помоему sh то везде должен по дефлоту быть

или я не прав?

semka

Ну, на крайняк можно: ln /bin/bash /bin/sh

Хотя если честно, ни одной POSIX системы без sh не видел.

caleb

Suse 10.0, 10.2, Slax 5.1.8, Slackware 11, Vista 1.0 beta (последнее шутка)

я конечно ламер, но не надо насмехаться.

делаю просто rpm -ihv netherearth(версия такая то).rpm

и все тут то и ошибка

fly4life

Что в SuSE показывают команды:

rpm -qf `which sh`
ls -l `which sh`
Heavy

А никак не написать В ТОЧНОСТИ, что за ошибка?

caleb

linux-rtkb:/home/scrap # rpm -qf `which sh`

bash-3.1-55

linux-rtkb:/home/scrap # ls -l `which sh`

lrwxrwxrwx 1 root root 9 Dec 17 19:48 /usr/bin/sh -> /bin/bash

linux-rtkb:/home/scrap # ln /bin/bash /bin/sh

ln: creating hard link `/bin/sh’: File exists

linux-rtkb:/home/scrap # linux-rtkb:/home/games # rpm -ihv netherearth-0.41-kuznecov1.i686.rpm

error: Failed dependencies:

sh is needed by netherearth-0.41-kuznecov1.i686

Uncle Theodore
caleb
linux-rtkb:/home/scrap # rpm -qf `which sh`

bash-3.1-55

linux-rtkb:/home/scrap # ls -l `which sh`

lrwxrwxrwx 1 root root 9 Dec 17 19:48 /usr/bin/sh -> /bin/bash

linux-rtkb:/home/scrap # ln /bin/bash /bin/sh

ln: creating hard link `/bin/sh’: File exists

linux-rtkb:/home/scrap # linux-rtkb:/home/games # rpm -ihv netherearth-0.41-kuznecov1.i686.rpm

error: Failed dependencies:

sh is needed by netherearth-0.41-kuznecov1.i686

Больше никаких депендонсов он не требует?

тады

pm -Uvh —force —nodep netherearth-0.41-kuznecov1.i686.rpm

и дет оно все обратно! :P

Good Luck,

UT

Genie

думается мне, что оно попросит при запуске какую древнюю LIBC… ну это так, чисто подозрение..

caleb

rpm -Uvh —force —nodeps paket-bal.bla.bla.rpm

работает ;) спасибо за подсказку, те несколько прог, что не мог поставить, прекрасно заработали

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.