nixp.ru v3.0

18 января 2017,
среда,
23:16:49 MSK

Аутсорсинг Linux с компанией «Флант»
IzumeR00t написал 7 февраля 2007 года в 21:16 (434 просмотра) Ведет себя неопределенно; открыл 1 тему в форуме, оставил 1 комментарий на сайте.

Заказал я дополнительные пакеты к федоре. Ну, давай же ставить… Хотел поддержку mp3 забахать. Вот что получается:

[root@localhost izumeroot]# yum install lame-mp3x

Loading «installonlyn» plugin

Setting up Install Process

Setting up repositories

Reading repository metadata in from local files

Parsing package install arguments

Resolving Dependencies

—> Populating transaction set with selected packages. Please wait.

—> Package lame-mp3x.i386 0:3.97-3.lvn6 set to be updated

—> Running transaction check

—> Processing Dependency: libgdk-1.2.so.0 for package: lame-mp3x

—> Processing Dependency: lame = 3.97-3.lvn6 for package: lame-mp3x

—> Processing Dependency: libgtk-1.2.so.0 for package: lame-mp3x

—> Processing Dependency: libglib-1.2.so.0 for package: lame-mp3x

—> Processing Dependency: libgmodule-1.2.so.0 for package: lame-mp3x

—> Restarting Dependency Resolution with new changes.

—> Populating transaction set with selected packages. Please wait.

—> Package gtk+.i386 1:1.2.10-55.fc6 set to be updated

—> Package lame.i386 0:3.97-3.lvn6 set to be updated

—> Package glib.i386 1:1.2.10-23.fc6 set to be updated

—> Running transaction check

—> Processing Dependency: libmp3lame.so.0 for package: libquicktime

—> Processing Dependency: lame-libs = 3.97-3.lvn6 for package: lame

—> Processing Dependency: libmp3lame.so.0 for package: lame

—> Processing Dependency: libmp3lame.so.0 for package: ffmpeg

—> Processing Dependency: libmp3lame.so.0 for package: lame-mp3x

—> Restarting Dependency Resolution with new changes.

—> Populating transaction set with selected packages. Please wait.

—> Package lame-libs.i386 0:3.97-3.lvn6 set to be updated

—> Package libquicktime.i386 0:0.9.10-2.lvn6 set to be updated

—> Running transaction check

—> Processing Dependency: libavutil.so.49 for package: libquicktime

—> Processing Dependency: libavcodec.so.51 for package: libquicktime

—> Finished Dependency Resolution

Error: Missing Dependency: libavutil.so.49 is needed by package libquicktime

И главное, что

[root@localhost izumeroot]# find /usr/lib -name libavutil*

/usr/lib/libavutil.so

/usr/lib/libavutil-CVS.so

/usr/lib/libavutil.so.49

[root@localhost izumeroot]# find /usr/lib -name libavcodec*

/usr/lib/libavcodec.so

/usr/lib/libavcodec-CVS.so

/usr/lib/libavcodec.so.51

[root@localhost izumeroot]#

Причем /usr/lib/libavutil.so.49 и /usr/lib/libavcodec.so.51 — симлинки сделанные мной. Почему yum не находит, что у меня есть эти библиотеки и как корректно поставить это? Таких случаев у меня не мало. Всегда хотел узнать, как разрулить.

Еще одна еще более удивительная вещь!

[root@localhost izumeroot]# yum install kmod-fglrx.i586

Loading «installonlyn» plugin

Setting up Install Process

Setting up repositories

Reading repository metadata in from local files

Parsing package install arguments

Resolving Dependencies

—> Populating transaction set with selected packages. Please wait.

—> Package kmod-fglrx.i586 0:8.29.6-1.2.6.18_1.2849.fc6 set to be installed

—> Running transaction check

—> Processing Dependency: kernel-i586 = 2.6.18-1.2849.fc6 for package: kmod-fglrx

—> Processing Dependency: fglrx-kmod-common >= 8.29.6 for package: kmod-fglrx

—> Restarting Dependency Resolution with new changes.

—> Populating transaction set with selected packages. Please wait.

—> Package xorg-x11-drv-fglrx.i386 0:8.29.6-1.lvn6 set to be updated

—> Running transaction check

—> Processing Dependency: kernel-i586 = 2.6.18-1.2849.fc6 for package: kmod-fglrx

—> Finished Dependency Resolution

Error: Missing Dependency: kernel-i586 = 2.6.18-1.2849.fc6 is needed by package kmod-fglrx

И это при том, что

[root@localhost izumeroot]# yum list | grep kernel

kernel.i586 2.6.18-1.2798.fc6 installed

kernel-devel.i586 2.6.18-1.2798.fc6 installed

kernel-headers.i386 2.6.18-1.2798.fc6 installed

Как правильно разрулить?

IzumeR00t

Вот еще установил я амарок из дополнительных пакетов. Установилось всё на ура. А вот при запуске.

[izumeroot@localhost ~]$ amarok

Amarok: [Loader] Starting amarokapp..

Amarok: [Loader] Don’t run gdb, valgrind, etc. against this binary! Use amarokapp.

amarokapp: error while loading shared libraries: /usr/lib/xorg/libGL.so.1: cannot restore segment prot after reloc: Permission denied

[izumeroot@localhost ~]$

ecobeingecobeing.ru
Экология и вегетарианство на благо всем живым существам Планеты.